Certbot --apache

#1

An unexpected error occurred:
ContextualVersionConflict: (pyOpenSSL 0.13.1 (/usr/lib64/python2.7/site-packages), Requirement.parse(‘pyOpenSSL>=0.14; extra == “security”’), set([‘requests’]))
Please see the logfile ‘/tmp/tmpCDQugx’ for more details.

My web server is (include version):apache

The operating system my web server runs on is (include version):centos7.6

My hosting provider, if applicable, is: Ali cloud

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot-0.30.2-1.el7.noarch

#2

Any chance that you upgraded requests or any other Python package via pip, outside of yum? Maybe check out this comment.

#3

I execute the following orders
pip uninstall requests
yum reinstall python-requests

pip uninstall six
yum reinstall python-six

pip uninstall urllib3
yum reinstall python-urllib3

But the use of certbot --apache
An unexpected error occurred:
UnknownExtra: requests 2.6.0 has no such extra feature ‘security’
Please see the logfile ‘/tmp/tmpWysFLh’ for more details.

#4

I didn’t mean for you to run those commands immediately, just to check whether you have been installing Python packages outside of yum (which causes conflicts).

Regarding this issue, I believe this could help:

yum -y reinstall python2-acme certbot

But if not, you might try giving certbot-auto a go. It’s hard to know what state your Python packages are in, but certbot-auto runs in a way that isolates its dependencies and should work around any issues that you are having.

#5

I execute the following orders

yum -y reinstall python2-acme certbot

But the use of certbot --apache
Traceback (most recent call last):
File “/usr/bin/certbot”, line 5, in
from pkg_resources import load_entry_point
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 3138, in
@_call_aside
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 3122, in _call_aside
f(*args, **kwargs)
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 3151, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 666, in _build_master
return cls._build_from_requirements(requires)
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 679, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 867, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The ‘certbot==0.30.2’ distribution was not found and is required by the application

But the use of rpm -qa |grep certbot
python2-certbot-0.30.2-1.el7.noarch
python2-certbot-apache-0.30.2-1.el7.noarch
certbot-0.30.2-1.el7.noarch

I found this version–certbot-0.30.2-1.el7.noarch

Do you want me to use certbot-auto? But certbot-auto is not centos6 version of the command?

I used certbot-auto -apache but bash popped up: certbot-auto: command not found

#6

It’s suitable for any distribution, not just CentOS 6. It can be helpful if your Python packages are messed up (like on your system).

You would need to run it like:

./certbot-auto

since it is not installed into your $PATH.

#7

I run it like:
./certbot-auto .
But appear
-bash: ./certbot-auto: No such file or directory .
alas

#8

Did you follow the installation instructions I linked a couple of posts earlier? https://certbot.eff.org/docs/install.html#certbot-auto

#9

No. I am from https://certbot.eff.org/lets-encrypt/centosrhel7-apache installation. I’ll try your installation method now. Thank you very much for your question

#10

I run it like :
user@webserver:~$ wget -N https://dl.eff.org/certbot-auto.asc

user@webserver:~$ gpg2 --keyserver pool.sks-keyservers.net --recv-key A2CFB51FA275A7286234E7B24D17C995CD9775F2

user@webserver:~$ gpg2 --trusted-key 4D17C995CD9775F2 --verify certbot-auto.asc certbot-auto

but apper
gpg: Signature made Fri 08 Feb 2019 05:26:55 AM CST using RSA key ID CD9775F2
gpg: Can’t check signature: No public key
I need to create the key myself?

#11

The GPG verification section is not strictly necessary.

If you’ve reached that point (assuming you ran the first wget and the chmod bit etc), you should be able to try now:

./certbot-auto
#12

but apper
Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

I’ve learned

1 Like
closed #13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.