Cert stuck in staging


#1

Hello

I had generated a cert using --staging a while ago for the domain southamptonsolentlions.org.uk now I wish to convert this to a live cert.

First I tried letsencrypt-auto certonly --webroot -w /home/soln0657/html -d www.southamptonsolentlions.org.uk -d southamptonsolentlions.org.uk which completed successfully but the cert is still happy hacker fake CA

I’ve also revoked the cert from --staging and regenerated again.

Is the staging flag saved in a config somewhere for this domain?

Thanks


#2

You did obtain a certificate today from LE ( actually 2 ) … I suspect that you just haven’t configured it properly on your server.

How did you configure your server with the “staging” certificate ? basically you just need to replace that one with the one you have obtained ( possibly already done, if you just pointed your config to /etc/letsencrypt/live ) and restart apache / nginx


#3

Hmm that’s what I thought… I also renewed other domains today which worked fine.

This is using apache2 on Fedora 20 I have done a reload which serves other domains with their new certs (https://owen.sayers.name/ for example)

This is the apache conf:

SSLEngine on SSLCertificateFile /etc/letsencrypt/live/southamptonsolentlions.org.uk/fullchain.pem SSLCertificateKeyFile /etc/letsencrypt/live/southamptonsolentlions.org.uk/privkey.pem


#4

I’d suggest looking in /etc/letsencrypt/live/ and the southamptonsolentlions.org.uk folder to check that there aren’t certs with -0001 on the end


#5

The new non staging certs were in a folder **www.**southamptonsolentlions.org.uk . I must have switched around the -d flags without realising.

Anyway all working now thanks for the help!


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.