Cerbot renew HTTPSConnectionPool(host='acme-v02.api.letsencrypt.org', port=443): Read timed out


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: cdr.ichirf.inidus.cloud

I ran this command: docker run -p 80:80 -p 443:443 -vpwd/letsencrypt:/etc/letsencrypt -it certbot/certbot renew --standalone

It produced this output:

My web server is (include version):

Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/cdr.ichirf.inidus.cloud.conf


Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator standalone, Installer None
Attempting to renew cert (cdr.ichirf.inidus.cloud) from /etc/letsencrypt/renewal/cdr.ichirf.inidus.cloud.conf produced an unexpected error: HTTPSConnectionPool(host=‘acme-v02.api.letsencrypt.org’, port=443): Read timed out. (read timeout=45). Skipping.


Processing /etc/letsencrypt/renewal/explorer.ichirf.inidus.cloud.conf


Cert not yet due for renewal
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/cdr.ichirf.inidus.cloud/fullchain.pem (failure)


The following certs are not due for renewal yet:
/etc/letsencrypt/live/explorer.ichirf.inidus.cloud/fullchain.pem expires on 2018-12-31 (skipped)
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/cdr.ichirf.inidus.cloud/fullchain.pem (failure)


1 renew failure(s), 0 parse failure(s)

The operating system my web server runs on is (include version):Ubuntu 16.04.4 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):No

This worked 3 months ago (former dev) and the odd thing is that after a number of similar failures the other cert ‘explorer.ichirf.inidus.cloud’ , was renewed succesfully last night.

Sorry I’m a real newbie in this space

curl -v acme-v02.api.letsencrypt.org/directory
curl -v acme-v01.api.letsencrypt.org/directory both seem alive.

as are
ping acme-v01.api.letsencrypt.org
ping acme-v02.api.letsencrypt.org

but

ping6 acme-v01.api.letsencrypt.org
ping6 acme-v02.api.letsencrypt.org

are both unreachable.

Any help much appreciated.

Ian


#2

Does the computer “claim” IPv6 connectivity? I.e., does it have IPv6 configured and does it try to connect to IPv6 hosts? E.g., Google and/or Facebook through IPv6?


#3

Thx,

No connectivity to Google or Facebook via IP6.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.