Can't validate SSL certificate

Hello,

I tried to move my domain from a dedicated to an other, and then I’m having a problem. The domain can’t be validated. I moved 6 others subdomains and it worked, but this one won’t work, idk why…

Here is my apache virtualhost config file: https://pastebin.com/3s2tYjRb

I tried to chmod to 777 the directory, still not working :confused:

My domain is: gmod.soleria.eu

I ran this command: /opt/letsencrypt/certbot-auto

It produced this output: https://pastebin.com/kr7PECk7

My web server is (include version): Apache/2.4.25

The operating system my web server runs on is (include version): Debian 9

My hosting provider, if applicable, is: OVH ( Dedicated server)

I can login to a root shell on my machine: yes

I'm not using a control panel to manage my site.

The version of my client is: certbot 0.34.2

Best regards,

Hi @Haeiven

your main configuration looks ok ( https://check-your-website.server-daten.de/?q=gmod.soleria.eu ):

Domainname Http-Status redirect Sec. G
http://gmod.soleria.eu/
37.187.134.85 200 0.053 H
https://gmod.soleria.eu/
37.187.134.85 200 0.550 N
Certificate error: RemoteCertificateNameMismatch
http://gmod.soleria.eu/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
37.187.134.85 404 0.057 A
Not Found
Visible Content: Not Found The requested URL /.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de was not found on this server. Apache/2.4.25 (Debian) Server at gmod.soleria.eu Port 80

Port 80 is open, checking a file in /.well-known/acme-challenge there is the expected result http status 404 - Not found.

Your port 80 DocumentRoot:

DocumentRoot /var/www/html/soleria/gmod_site/

So use it:

certbot-auto run -a webroot -i apache -w /var/www/html/soleria/gmod_site -d gmod.soleria.eu

Hello,

Still the having the same error :confused:

Logs: https://pastebin.com/G9kJMbUc

Best regards,

Then this isn’t the vHost Apache uses with this domain.

What says

apachectl configtest
apachectl fullstatus
apachectl -S

What’s that? - https://check-your-website.server-daten.de/?q=gmod.soleria.eu

CertSpotter-Id Issuer not before not after Domain names LE-Duplicate next LE
902650736 CN=Let’s Encrypt Authority X3, O=Let’s Encrypt, C=US 2019-05-09 16:29:23 2019-08-07 16:29:23 gmod.soleria.eu
1 entries
865917286 CN=“cPanel, Inc. Certification Authority”, O=“cPanel, Inc.”, L=Houston, C=US, ST=TX 2019-04-16 00:00:00 2019-07-15 23:59:59 gmod.soleria.eu, www.gmod.soleria.eu
2 entries

There is a cPanel certificate.

Never mix certbot and cPanel.

root@gmod:/opt/letsencrypt# apachectl configtest
Syntax OK


root@gmod:/opt/letsencrypt# apachectl fullstatus
/usr/sbin/apachectl: line 113: www-browser: command not found
'www-browser -dump http://localhost:80/server-status' failed.
Maybe you need to install a package providing www-browser or you
need to adjust the APACHE_LYNX variable in /etc/apache2/envvars

for the last command:
https://pastebin.com/GSMCt0vm

Cpanel certificate was on my old host, and is not used anymore

There you see the problem.

         default server gmod.soleria.eu (/etc/apache2/sites-enabled/000-default.conf:1)
         port 80 namevhost gmod.soleria.eu (/etc/apache2/sites-enabled/000-default.conf:1)
         port 80 namevhost classement.soleria.eu (/etc/apache2/sites-enabled/classement.conf:1)
         port 80 namevhost fastdl.soleria.eu (/etc/apache2/sites-enabled/fastdl.conf:1)
         port 80 namevhost gmod-boutique.soleria.eu (/etc/apache2/sites-enabled/gmod-boutique.conf:1)
         port 80 namevhost gmod.soleria.eu (/etc/apache2/sites-enabled/gmod.conf:1)

There is more then one gmod.soleria.eu.

Make a backup.

Then change the name of your default server to another (perhaps not used) name).

Combinations of port and servername should be unique.

Then use the DocumentRoot of gmod.conf.

1 Like

There’s nothing in 000-default.conf about that… https://pastebin.com/xgcqRzXA

I’m confused…

Okey, it finally worked !

My server hostname was “gmod” and the domain was “soleria.eu”

Then, my default apache host was gmod.soleria.eu

Thanks for helping :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.