Cannt install letsencrypt for Debian 8

Hello,

I am trying to install lets encrypt tomy Debian 8 vps, but it does not work for me. I tried a lot of manuals, but nothing work for me. Try to add lines to sources list debian jessie-backports main etc.

But nothing work.

For example if i use this https://certbot.eff.org/lets-encrypt/debianjessie-apache

when i use

  • sudo /usr/local/bin/certbot-auto --apache

i get error like

Err http://http.debian.net/debian/ jessie-backports/main python3-pkg-resources all 33.1.1-1~bpo8+1
404 Not Found [IP: 2a04:4e42:41::204 80]
E: Failed to fetch http://http.debian.net/debian/pool/main/d/dh-python/dh-python_2.20170125~bpo8+1_all.deb 404 Not Found [IP: 2a04:4e42:41::204 80]

E: Failed to fetch http://http.debian.net/debian/pool/main/p/python-setuptools/python3-pkg-resources_33.1.1-1~bpo8+1_all.deb 404 Not Found [IP: 2a04:4e42:41::204 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I try a lot of things, make update etc., but always i get similar error.

Is here any with experience and functional setup settings?

Thank you.

1 Like

It looks like there is no jessie-backports anymore (on the mirrors) http://cdn-fastly.deb.debian.org/debian/dists/

2 Likes

Thank you. I take a look, sometimes iget error Unable to fetch some archives, maybe run apt-get update or try with --fix-missing

Maybe i should use new debian?

1 Like

If you can, you should. If you cannot, you should read that answer from stackexchange and change the apt repositories.

2 Likes

Thank you. I did a lot of changes and i am in another step. I pu my email address,alll looks like certificate is generating, but then get error

The client lacks sufficient authorization :: Account creation on ACMEv1 is disabled. Please upgrade your ACME client to a version that supports ACMEv2 / RFC 8555. See End of Life Plan for ACMEv1 for details.

I am not sure what should i update/install

what version is your certbot? if it’s older than 0.22 you’re out of luck: https://github.com/certbot/certbot/blob/master/certbot/CHANGELOG.md#0220---2018-03-07

if it’s newer, you can use ACME v2, just edit /etc/letsencrypt/cli.ini or call certbot with

certbot --server https://acme-v02.api.letsencrypt.org/directory

Thank you. I am using certbot version: 0.10.2

When i cal your coomand and after i use sudo certbot --apache -d domain.com -d www.domain.com

I get another error

Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
An unexpected error occurred:
KeyError: ‘Directory field not found’

I check my files and there is no file with name cli.ini in /etc/letsencrypt/

Thank you :slight_smile:

you should definitely upgrade. if you cannot get a modern version of certbot, move to acme.sh or similar: https://letsencrypt.org/docs/client-options/

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.