Cannot stat sple.sh / rwssl: command not found


#1

Hey there folks, hope you are doing alright :slight_smile: I need some help and I couldn’t find anyone posting anything similar I run into the same issue on websites when trying to run the script

My domain is:newyork.impacthub.net

I ran this command:
git clone https://github.com/rehmatworks/serverpilot-letsencrypt.git && cd serverpilot-letsencrypt && sudo mv sple.sh /usr/local/bin/rwssl && sudo chmod +x /usr/local/bin/rwssl && (crontab -l ; echo “@monthly “sudo service nginx-sp stop && yes | letsencrypt --standalone renew &>/dev/null && service nginx-sp start && service nginx-sp reload””)| crontab - && service cron reload

and

rwssl

It produced this output:
Cloning into ‘serverpilot-letsencrypt’…
remote: Counting objects: 804, done.
remote: Compressing objects: 100% (52/52), done.
remote: Total 804 (delta 57), reused 55 (delta 31), pack-reused 721
Receiving objects: 100% (804/804), 200.95 KiB | 0 bytes/s, done.
Resolving deltas: 100% (464/464), done.
Checking connectivity… done.
mv: cannot stat ‘sple.sh’: No such file or directory

rwssl: command not found

My web server is (include version): PHP 7.1 / 7.2 (i tried both just in case if this is what you mean by server version)

The operating system my web server runs on is (include version):Ubuntu 16.04.4 x64

My hosting provider, if applicable, is:DigitalOcean/Server Pilot

I can login to a root shell on my machine (yes or no, or I don’t know): YES

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): NO

I even tried pulling the file manually, is there anything that I am doing wrong?
Thanks a bunch!


#2

It looks like the install instructions for this plugin have changed recently. Please follow the updated install instructions at:


#3

Awesome it worked, thank you Patches, well I hope it will help someone with the same problem :slight_smile:

Cheers y’all!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.