Cannot renew certbot

hello, i cannot renew my certificates using certbot, it says that there is no certificates in there, and i'm using nginx

root@dev:/etc/nginx/sites-available# sudo certbot renew
Saving debug log to /var/log/letsencrypt/letsencrypt.log


No renewals were attempted.


and then i check nginx -t, but the output is this error that says cannot load certificates

nginx failed to start because it could not find certificate in that places:
maybe try renew with --standalone? it'll likely fix this problem itself but it'd make another problem about renewal after this, so please post result of that command

3 Likes

after i used sudo certbot certonly --standalone -d kiosk.dev.intanbanjar.id, it says that could not bind TCP port 80 because it is already in use by another process
then i disable my nginx server, after that i try again and then it worked, but i cannot start my nginx

thank you, its done

im deleting the script on my nginx/sites-available/ that generated by previous certbot, and then the nginx worked

3 Likes