Cannot move `certbot-auto' permission denied

My domain is:

I ran this command: sudo mv certbot-auto /usr/local/bin/certbot-auto

It produced this output: mv: cannot move certbot-auto' to /usr/local/bin/certbot-auto’: Permission denied

My web server is (include version): apache

The operating system my web server runs on is (include version): debian squeeze

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): -bash: certbot: command not found

I am trying to install certbot by following the suggested steps for apache with debian squeeze:

  1. SSH into the server running your HTTP website as a user with sudo privileges
    that was done
  2. wget
    that did not work. (unable to establish SSL connection) But i found a workaround (or so i think) by downloading the certbot-auto file to my home directory and then moving it into the server by use of scp. It now lies there in the home directory.
  3. sudo mv certbot-auto /usr/local/bin/certbot-auto
    I do not seem to have permission to do this. (error message see above)

Any suggestions why I am not allowed to move the file? i experimentally changed the permissions for certbot-auto and still cannot move the file so i assume the issue is with the target directory.

Thanks for your suggestions. I am quite new to this and have only done it before (for a ubuntu 16 server and that worked smoothly).

1 Like

certbot-auto can technically be run from any directory.
So just chmod it properly and run it from wherever it is:

Br sure there are no other (previous) copies of certbot-auto nor certbot anywhere:
sudo find / -name certbot-auto
sudo which certbot-auto
sudo find / -name certbot
sudo which certbot

1 Like

Thanks for the reply!

I ran the suggested lines of code. However, because I was not logged in as root, i did not have access and just generated a whole long list of messages that I did not have access.

Anyway, I eventually managed to log in as root and moving was not a problem anymore.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.