Cannot install Let's Encrypt: CAA SERVFAIL

I am trying to install Let’s Encrypt on .
I got this error:

Invalid response from
Type: urn:acme:error:connection
Status: 400
Detail: DNS problem: SERVFAIL looking up CAA for ru

This is because my domain register cannot set a CAA record.
Is there an alternate way to go forward?

Can you explain it, please?
Thank You

Hi @apocanow,

Seems a DNSSEC problem on TLD .ru

Take a look to this post LE is failing CAA on TLD


Hi @sahsanu and thanks for the reply.

My domain registar said that they cannot set a CAA record. It can be a co-cause? I read that post and it seems a “temporary issue” of .ru domains. Am I wrong?

It also seems that I cannot do anything If not “wait”. Am I wrong?


No, there is no need to add a CAA record only that your DNS servers answer correctly saying ok, you are requesting a CAA record but I've no info, that is ok. I've checked your domain and it is not your fault.

Yes, seems it is temporary.

Correct, it is not your fault and you can do nothing to solve it... just wait.


1 Like

Thanks, @sahsanu. Very kind.

I appreciate the help you gave to me. I hope you can assist me if I have further problems.
In the while, I will wait.


1 Like

@apocanow, other users are reporting they can issue certs for .ru domains again so maybe you could try to issue the cert for your domain.

Now, dnsviz reports no DNSSEC issues for .ru TLD

1 Like

Hi @sahsanu. Sorry for not updating. I tried some minutes ago, and it worked for me too. Thank you for everything :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.