Cannot install a SSL certificate

I have a problem with installing an SSL certificate with certbot on Ubuntu.

2017-11-20 19:57:50,640:DEBUG:certbot.error_handler:Calling registered functions
2017-11-20 19:57:50,642:DEBUG:certbot.reporter:Reporting to user: Unable to install the certificate
2017-11-20 19:57:50,642:DEBUG:certbot.log:Exiting abnormally:
Traceback (most recent call last):
  File "/opt/", line 11, in <module>
  File "/opt/", line 861, in main
    return config.func(config, plugins)
  File "/opt/", line 705, in run
    _install_cert(config, le_client, domains, new_lineage)
  File "/opt/", line 565, in _install_cert
    path_provider.cert_path, path_provider.chain_path, path_provider.fullchain_path)
  File "/opt/", line 452, in deploy_certificate
  File "/opt/", line 253, in deploy_cert
    vhost = self.choose_vhost(domain)
  File "/opt/", line 347, in choose_vhost
    vhost = self.make_vhost_ssl(vhost)
  File "/opt/", line 852, in make_vhost_ssl
    self._copy_create_ssl_vhost_skeleton(nonssl_vhost, ssl_fp)
  File "/opt/", line 998, in _copy_create_ssl_vhost_skeleton
    ssl_vh_contents, sift = self._sift_rewrite_rules(orig_contents)
  File "/opt/", line 1070, in _sift_rewrite_rules
    line = next(contents)

This error occurs (I tried reinstalling certbot).
Please help, I have tried to resolve this for 2 days.

Hi @michalrokita,

What version of Certbot is this? It looks like you’ve found a bug in Certbot.

Cc @bmw

@michalrokita, sorry for the trouble! Please open a bug report against Certbot at answering the questions prepopulated in the form and we’ll be better able to help you.

The version on my system is certbot 0.19.0

I created an issue on GitHub, aprox. how long will it take to resolve?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.