Cannot get HTTPS to work: PR_END_OF_FILE_ERROR

My domain is:

I ran this command: certbot (selecting the index for the correct domain)

It produced this output: Congratulations! You have successfully enabled

My web server is (include version): NGINX/1.18.0

The operating system my web server runs on is (include version): Debian 11

My hosting provider, if applicable, is: self-hosted

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.12.0

I've been trying to get HTTPS to work on my new domain ( Oddly, the website runs completely fine with HTTPS on my home network, but if I try and connect from outside my home network only HTTP works and I get a SSL error PR_END_OF_FILE_ERROR if I attempt to use HTTP.

I just timeout trying https to your site but http works fine. Maybe check your router to ensure it is passing through port 443 as it does with port 80.


After you fix that, you might want to also include the "www" name (in DNS and in the cert).


My router was set to pass port 443, and it was working fine before. For some odd reason deleting the rule and recreating it worked. Thanks for the help!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.