Cancel auto renewal of certificates


#1

I have auto renewal for my certificates, for some reasons I want to cancel the auto renewal.
How can I do that?
I want to cancel for all active domains with certificates.

this is how I issued my certificates:
sudo certbot-auto --apache

Apache
Ubuntu 14.04.5 LTS
SSH connection to the ubuntu machine


#2

Hi @nirbenya

there should be a cron-, at or systemd - job you should stop.

Check /etc/crontab/, /etc/cron.*/* and systemd timers ( systemctl list-timers ).

In /etc/letsencrypt/renewal there are certificate specific configuration options. You “can” add wrong commands / options to block a renew. But this is not really a good idea.


#3

HI @JuergenAuer, Thanks.

I’ll take a look at the cron files.

What about deleting the /etc/letsencrypt/renewal folder?


#4

If you want to prevent all future auto-renewal of certificates on this server, you should disable the cron job or systemd timer.

If you want to disable auto-renewal for the certificates you currently have, but still be able to auto-renew any new certificates that you may obtain in the future, you should instead delete the files inside the /etc/letsencrypt/renewal folder (back them up first in case you change your mind).


#5

With recent versions of Certbot, you can just set “autorenew = False” in the renewal configuration files. (Or something like that. I might have it wrong.)


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.