Can´t generate new SSL certificates and dont know why

My domain is:

I ran this command:
certbot certonly --config "/etc/letsencrypt.ini" --work-dir "/tmp/letsencrypt-lib" --logs-dir "/tmp/letsencrypt-log" --cert-name "npm-8" --agree-tos --authenticator webroot --email "" --preferred-challenges "dns,http" --domains ""

It produced this output:
:warning: warning Command failed: certbot certonly --config "/etc/letsencrypt.ini" --work-dir "/tmp/letsencrypt-lib" --logs-dir "/tmp/letsencrypt-log" --cert-name "npm-8" --agree-tos --authenticator webroot --email "" --preferred-challenges "dns,http" --domains ""

And in the webUI of Ngix i get this prompt:
at ChildProcess.exithandler (node:child_process:402:12)
at ChildProcess.emit (node:events:513:28)
at maybeClose (node:internal/child_process:1100:16)
at Process.ChildProcess._handle.onexit (node:internal/child_process:304:5)

The operating system my web server runs on is (include version):
im runing Ngix proxy manager in a docker container in Ubuntu last 22.04

I can login to a root shell on my machine (yes or no, or I don't know):
i cant access to the container bash, it prompts an error

Basically a few days ago i generates a SSL certificate using Ngix Proxy manager and it worked lovely but today i realised i new another certificate for another domain but it wont generate it, just prompts this error over and over again, no mather what i do, tried to recreate the container and even get the whole system to a past version as im doing all this in a virtual machine. Thanks in advance for the help.

Do you have port 80 open on this IP address/virtual machine?

It doesn't look like it. I can see port 443 is open, but not 80.

Port 80 needs to be open and accessible for you to be able to get a certificate using --webroot.


I have de port 80 closed right now because im just testing things and a bit afraid of having a port open with nothing behind it but i opened the port in the router when trying to get the certificate, also opened the port in the windows firewall and redirected to 80 port of VM with virtualbox

And i know that Ngix is redirecting fine and that the service is up because i can load the website and see it and even login

Nevermind bro i tried opening the por 80 and then restarting the container and it worked, its allways the silliets little things hahahha thank you so much for the help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.