Can certbot-auto work with Owncloud?


#1

My domain is: not relevant
I ran this command: certbot-auto
It produced this output: It ran as expected
My web server is (include version): Apache 2.4.18
The operating system my web server runs on is (include version): Ubuntu 16.04.4 LTS
My hosting provider, if applicable, is: self
I can login to a root shell on my machine (yes or no, or I don’t know): yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

certbot-auto worked flawlessly except it broke the Owncloud installation.
Had to revert to previous snapshot…
So the question is:
How can I get certbot-auto installed without breaking Owncloud?


#2

Hi @rg305,

I don’t use apache installer with certbot-auto because I don’t want to mess my conf files so I don’t know how certbot-auto modifies your conf files to break the owncloud conf.

What I do is to use an Alias in Apache conf and certbot-auto using webroot authenticator and it works pretty well with my owncloud installation.

1.- Add an Alias directive to your /etc/apache2/apache2.conf (I don’t know if Ubuntu uses another name for this conf file)

Alias "/.well-known/acme-challenge" "/var/www/letsencrypt/.well-known/acme-challenge"

2.- Issue the certificate for your domain.

certbot-auto certonly -a webroot -w /var/www/letsencrypt -d yourdomain.tld

3.- Create the right apache ssl conf for your domain.

4.- Reload or restart apache

I know it doesn’t answer your question but… :wink:

Good luck,
sahsanu


#3

I’m not certain what break nor where.
So there might be modifications to the apache2.conf file that affect owncloud.
But the problem I think is mainly in that both use python/php and certbot-auto steps over some setting owncloud can’t recover from.
After certbot-auto first run and it installs all it’s dependencies, owncloud doesn’t show any dependency problems but it just fails to function.
I will try to recreate this in more of a lab environment and get back with any findings…


#4

The problem was with the newly created 000-default-le-ssl.conf file; which overlapped with the 000-default.conf file for port 443.
I guess certbot/certbot-auto likes port 80 and port 443 to be in separate vhost files.
Now 000-default.conf only serves port 80
and 000-default-le-ssl.conf only serves port 443


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.