CAA record prevents issuance

My domain is: www.blogggly.com/

I ran this command: sudo certbot certonly --nginx --dry-run -d www.blogggly.com -d blogggly.com

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for www.blogggly.com
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. www.blogggly.com (http-01): urn:ietf:params:acme:error:caa :: CAA
record for www.blogggly.com prevents issuance

    IMPORTANT NOTES:
     - The following errors were reported by the server:

       Domain: www.blogggly.com
       Type:   None
       Detail: CAA record for www.blogggly.com prevents issuance

My web server is (include version): nginx/1.14.0

The operating system my web server runs on is (include version): Ubuntu 18.04 x64

My hosting provider, if applicable, is: Digital Ocean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

Hi @Asaf-Aviv

there is a check of your domain ( https://check-your-website.server-daten.de/?q=blogggly.com#caa ):

There you see the problem.

Domainname flag Name Value ∑ Queries ∑ Timeout
www.blogggly.com 5 issue blogggly.com 1 0
blogggly.com 5 issue letsencrypt.org 1 0
com 0 no CAA entry found 1 0

Only blogggly.com is allowed to create certificates for www.blogggly.com.

Letsencrypt isn’t allowed :wink:

Remove that wrong CAA entry.

blogggly.com has the correct entry.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.