CAA issue error not clear what is wrong

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this command:using cert-manager Docker image for auto-cert renewal

It produced this output:

E0517 18:03:31.698256 1 sync.go:356] cert-manager/controller/challenges/acceptChallenge "msg"="error waiting for authorization" "error"="acme: authorization error for 403 urn:ietf:params:acme:error:caa: CAA record for prevents issuance" "dnsName"="" "resource_kind"="Challenge" "resource_name"="tls-secret-new-ggxm9-3006079906-481070845" "resource_namespace"="default" "resource_version"="v1" "type"="DNS-01"

My web server is (include version):nginx 1.19.6

The operating system my web server runs on is (include version): Nginx Docker

My hosting provider, if applicable, is:Azure Kubernetes

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

I had to delete my CAA record to get a cert issued for now.
Record had Flags: 0, tag: issue, value ""
All per LetsEncrypt documentation. I expected this to work and it caused cert issuance to fail.

Hi @dbrennan

now you have a certificate.

Can you create that CAA entry again? May be there is a problem with your dns.

PS: But a raw check doesn't show problems, doesn't look like a DNSSEC problem because DNSSEC isn't used.

Are you sure there was no typo?

1 Like

Hi @JuergenAuer ,
I've recreated the record. It didn't seem like there was a typo.

Thanks. There is no problem visible -

Not with your CAA entries, not with your name servers, DNSSEC isn't used. Same result with a local unbound and unboundtest -

And there is no typo (#comments part):

A good: CAA entries found, creating certificate is limited: is allowed to create certificates
A good: CAA entries found, creating certificate is limited: is allowed to create certificates

So I don't find a reason why it didn't worked.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.