Browser is complaining that my certificate is invalid, how to fix this?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot --nginx

It produced this output:
Deploying certificate
Successfully deployed certificate for to /etc/nginx/sites-enabled/crispy

My web server is (include version): Nginx 1.18

The operating system my web server runs on is (include version): Ubuntu 20.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No Cpanel

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.23.0

1 Like

I see a brand new certificate issued today? Is your browser still complaining?


Your certificate is only valid for and not for

Edit your nginx config to add the second name, and run the certbot command again.


Yes i just created a new one five minutes ago to try again. Its not only me few people has complained about this.

thank you i will try that

1 Like

add the --dry-run option, before you get ratelimited.


it worked thank you :slight_smile:

1 Like

You've created A LOT of certificates recently:

I urge you NOT to keep re-issuing certs if you don't fully understand the issue at hand. Your actions could lead to running into rate limits. Please be more careful in the future.


what happens if i reach the limits?

Then you won't be able to issue new certificates for 7 days. Please see the Let's Encrypt documentation.


ohh okay thanks for letting me know that didnt happen yet i will make sure to run the --dry-run next time

1 Like

Question, how can you tell how many certificate i created?is there a tool i can use to see this?


Open the link in the post.

Also check letsdebug-toolkit


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.