BIO_new_file, there is no live folder in /etc/letsencrypt


#1

My domain is: ss1.proworktree.com

I ran this command: sudo nginx -t

It produced this output:
nginx: [emerg] BIO_new_file("/etc/letsencrypt/live/ss1.proworktree.com/fullchain.pem") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen(’/etc/letsencrypt/live/ss1.proworktree.com/fullchain.pem’,‘r’) error:2006D080:BIO routines:BIO_new_file:no such file)
nginx: configuration file /etc/nginx/nginx.conf test failed

My web server is (include version):

The operating system my web server runs on is (include version): debian 9

My hosting provider, if applicable, is: GoDaddy

I can login to a root shell on my machine (yes or no, or I don’t know): yeah.


#2

Hi,

Can you try run this command and share the certificate folder name (full path?)

sudo certbot certificates

Thank you


#3

umm actually it says,
Saving debug log to /var/log/letsencrypt/letsencrypt.log


No certs found.

but i did as mentioned in blog.


#4

Hi,
That means you don’t have any certificate installed.

Can you share us the blog you refer to?

Thank you


#5

I followed this command again :-
./letsencrypt-auto certonly --standalone in /opt/letsencrypt
but this time i am getting:-

  • The following errors were reported by the server:

    Domain: ss1.proworktree.com
    Type: connection
    Detail: Fetching
    http://ss1.proworktree.com/.well-known/acme-challenge/zt4EfA-dmhZTkq6rAPp7mAVOftf1JXa2Bc3EFnibf5s:
    Timeout

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

also i was able to ping ss1.proworktree.com before


#6

Hi,

Your port 80 and 443 was blocked.

Please enable those port and try again.(at least enable port 80)

Thank you


#7

i believe it is already enabled…
see this:
Status: active

To Action From


OpenSSH ALLOW Anywhere
80/tcp ALLOW Anywhere
443/tcp ALLOW Anywhere
OpenSSH (v6) ALLOW Anywhere (v6)
80/tcp (v6) ALLOW Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)

thank you.


#8

Hi,

Can you check your digital ocean firewall settings? (The setting on your cp)

Thank you


#9

kindly elaborate about the setting that i have to look for :sweat_smile:
as ipv4 and ipv6 are enabled, also no firewall is activated for now.
thanks :slight_smile:


#10

Thanks for the help so far @stevenzhu but i need a little more help to get it working.
thanks.


#11

Kay.

Is there any nginx/Apache currently running?
If not, can you try to run a instance so I can check what’s the issue?

Thank you


#13

hello,
i tried " systemctl status nginx.service" and got this.

nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2018-03-24 05:49:56 UTC; 1min 1s ago
Docs: man:nginx(8)
Process: 24843 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)
Main PID: 11802 (code=exited, status=0/SUCCESS)

and before this i tried killing the process to make the port 80 free.


#14

Hi,

Next time, can you try this command instead of just kill the Nginx process…
sudo systemctl stop nginx

Also, it seems that your http port is open now.
Can you try run certbot in nginx mode?
./letsencrypt-auto certonly --nginx in /opt/letsencrypt (just change standalone to nginx)
Also, i think if you need to use standalone you need to stop nginx first (Don’t kill the process!)

Thank you


#15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.