Avec https mon site est inaccessible

Veuillez remplir les champs ci-dessous pour que nous puissions vous aider. Remarque : vous devez fournir votre nom de domaine pour obtenir de l’aide. Les noms de domaine des certificats émis sont tous rendus publics dans les journaux de Transparence de Certificat (par exemple, https://crt.sh/?q=example.com). Par conséquent, le fait de ne pas indiquer votre nom de domaine ici n’aide pas à le garder secret, mais rend plus difficile pour nous le fait de vous aider.

Je peux lire des réponses en Anglais :
oui
Mon nom de domaine est :
lesoirdetunisie.tn
J’ai exécuté cette commande :
ouvrir mon site avec https
Elle a produit cette sortie :
ce site est inaccessible
Mon serveur Web est (inclure la version) :
nginx/1.19.1
Le système d’exploitation sur lequel mon serveur Web s’exécute est (version incluse) :
mac osx ElCapitan 10.11.6
Mon hébergeur, le cas échéant, est :
non je travalle seul
Je peux me connecter à un shell root sur ma machine (oui ou non, ou je ne sais pas) :
oui
J’utilise un panneau de configuration pour gérer mon site (non, ou fournit le nom et la version du panneau de configuration) : non

Bonsoir @nedhirazouz,

Désolé pour la réponse en anglais.

It looks like your server refuses connections on port 443. You might need to edit your nginx configuration to make sure that it has a server block with listen 443 ssl and a reference to your certificate and private key. Depending on how you obtained your certificate, the nginx configuration may not have been updated to make nginx aware of its existence.

2 Likes

Hello;
in the nginx.conf 443 is open, certificates are there and It works well with http.

server {
    listen 80;

    server_name lesoirdetunisie.tn;


    root /Library/WebServer/Documents;
    index index.php index.html;
}
server  { 
    listen  5500;
    listen [::]:443 ssl;

ssl_certificate /etc/letsencrypt/live/lesoirdetunisie.tn/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/lesoirdetunisie.tn/privkey.pem;
ssl_trusted_certificate /etc/letsencrypt/live/lesoirdetunisie.tn/chain.pem;
ssl_protocols TLSv1.2 TLSv1.3;
ssl_session_cache shared:le_nginx_SSL:1m;
ssl_session_timeout 1440m;
ssl_prefer_server_ciphers on;
ssl_session_tickets off;
ssl_stapling off;
ssl_stapling_verify on;
resolver 8.8.8.8 8.8.4.4 valid=300s;
resolver_timeout 5s;
ssl_ecdh_curve secp384r1;

    server_name localhost lesoirdetunisie.tn www.lesoirdetunisie.tn;
        location  /  { 
        root  /Library/WebServer/Documents;
                    }
        location /live  { 
        types {
            application/vnd.apple.mpegurl m3u8;
             }

        alias /Users/mac/www/lesoirdetunisie/hls/1234;
        add_header Cache-Control no-cache;
                    } 
         }
    }

You could confirm that this is working locally as you expect with

curl -k https://localhost:443/

or even better

curl https://lesoirdetunisie.tn/

from the server machine itself.

If those succeed, then you probably have a firewall that is blocking, or failing to forward, connections through to the server on port 443, even though it allows them on port 80.

Hello
This is the output.
curl: (7) Failed to connect to lesoirdetunisie.tn port 443: Connection refused
what do i have to do now?

Hello again
I try to open 443 port after several time and i succeed.
with sudo nc -lk 443
port 443 is now open, but i have this error: curl: (35) Server aborted the SSL handshake
have you got an issue to this error?
Thank you

Check in /var/log/nginx/error.log. You have some peculiar options set related to OCSP and client certificates, so it's worth checking whether that's generating any error logs.

Edit: that's probably not the right folder on macOS, maybe it's in /usr/local/etc/nginx/logs/ or something.