Automatic update Let’s encrypt did not work! [with EasyEngine]


#21

I’m not sure, but I think the cloudflare may have prevented this renewal.


#22

I’m glad it’s working!

You might still want to try to figure out why the version that uses the ee command didn’t work properly, since that was what the EasyEngine developers apparently expected would work.

Also, I don’t think Cloudflare is to blame. Cloudflare prevents some certificate renewals that are using apache or nginx authentication methods. But the content of your renewal configuration file shows that you are using webroot (see the line that says authenticator = webroot), which doesn’t have that particular problem.


#23

I am citing the cloudflare because there where the problem started, when I went to access the site today and it was off the air and had this cloudflare alert.

After I hung up the clodflare showed the certificate expired alert.

Then I came to the conclusion that it had not been automatically renewed.

I was using Full SSL (Strict) as indicated by cloudflare support.


#24

In this case, I think Cloudflare merely accurately detected a pre-existing problem (the certificate expiration) which would also have been a problem if you were not using Cloudflare.


#25

Thinking this way really think you’re right. I had not thought of it that way!


#26

I had a similar error, but I run my own VPS server (Ubuntu 16.04, nginx)…

In my case, my certs stopped renewing and the error said the server could not reach the site (since it was stopped via my original cron job), got 403 errors when not stopping it, etc.

What ended up solving my problem was that in my nginx config under port 80, I have the “.well-known” alias set and I auto-forward people to port 443 when 80 is hit. I ended up putting the “.well-known” directive in the port 443 nginx section as well.

After doing that, the renewals worked fine and I didn’t even need to stop and start nginx like I originally had to do. Down the road, I modified my cron job to just do the renewal and not start/stop nginx.

This even worked for 2 sites I have behind cloudflare.


closed #27

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.