Auto ssl on direct admin - failing for mail


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.animalenrichmentaustralia.com

I ran this command: On my new host server, with direct admin, I selected ’ Free & automatic certificate from Let’s Encrypt’ as instructed by my new host. I selected my site, smtp and mail.

It produced this output: It failed on the mail. entry, but meant that I had no operational ssl. Had to re-do it and leave out the mail. option. Now I have a working ssl, but still have a security error on emails.
I do have screenshots/error codes that I can provide if you can provide a way for me to send these to you.

My web server is (include version): not sure

The operating system my web server runs on is (include version): not sure

My hosting provider, if applicable, is: Swift designs/John Cook/ fastaffordablewebdesign.com.au

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): direct admin, don’t know which version


#2

Hi @Kirsty

what does this mean? Your ssl-certificate

https://www.animalenrichmentaustralia.com/

looks good, created today. And your certificate has 4 names:

DNS-Name: animalenrichmentaustralia.com
DNS-Name: mail.animalenrichmentaustralia.com
DNS-Name: smtp.animalenrichmentaustralia.com
DNS-Name: www.animalenrichmentaustralia.com

A Letsencrypt-certificate doesn’t have a smtp-information. So this is only the subdomain smt…

What does this mean? https://mail.animalenrichmentaustralia.com/ doesn’t work, but it’s the same ip-address. There is a wrong certificate installed (*.openrainbow.com, openrainbow.com).

Now there is a timeout. Edit - now it works - https://mail.animalenrichmentaustralia.com/ "Apache is functioning normally " - the certificate is correct!


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.