Authz Pending Limit

Hello,

i too encountered this rate limit today.
For me, it was a cronjob that tried to renew the certs every 12 hours and failed.
So finally i hit that limit.

I now want to delete / disable those pending requests, because sadly, it’s a production system :slight_smile:
I already tried the “LE_FIND_PENDING_AUTHZ.py” tool. But i always get this:

Reviewing Auth: owQWEx8raxoV8iV4-jcsWX4bT_l78EDzPcYO9zkQB-I’,
Status: 404 Unable to find authorization

So it looks like the authoizations my server created, dont exist.

Does anyone know a solution to this?
What can one do to clean those pending requests?

greetings from Vienna,

PS: of course i still get the
"There were too many requests of a given type :: Error creating new authz :: too many currently pending authorizations:" - errormessage.

it definitely exists: https://acme-v01.api.letsencrypt.org/acme/authz/owQWEx8raxoV8iV4-jcsWX4bT_l78EDzPcYO9zkQB-I

That ', at the end of output the looks super suspicious and is probably the reason that the tool is giving a 404. Perhaps check your input files and strip the ', away to make the tool work.

I wrote a similar tool here here if you continue to have trouble.

1 Like

God damn it :slight_smile:

You are completely right.
It looked like the ', was part of the debug output :slight_smile:

Thank you very much, and have a nice day!!!

regards

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.