Authority server no connection to my webserver

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot --apache

It produced this output:
root@mail1:~# certbot --apache
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Which names would you like to activate HTTPS for?


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel):
Renewing an existing certificate for

Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Type: connection
Detail: Fetching Connection refused

Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.

Some challenges have failed.
Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): raspbian (Debian 10)

The operating system my web server runs on is (include version): apache2/stable,now 2.4.38-3+deb10u5 armhf

My hosting provider, if applicable, is: myself

I can login to a root shell on my machine (yes or no, or I don't know): Yes, I do have.

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No, I only have shell access.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
root@mail1:~# certbot --version
certbot 1.18.0

So if I get the error message right, the authority server can not connect to my server. This error seams to occure because of a DNS problem cause my site IS available. But I can look up my A-records and I didn't change anything in my DNS configuration so if I ask Google-DNS, I get the correct answers.

As I said, I can open my own site (just get the security hint because of the certificate...) But when I try to open it over a webproxy, it won't work. I don't get this either.

Do I have open other ports on my firewall besides 80 and 443? Or do you have another ideas? It has worked few months ago.

1 Like

I can't get to your site from my home, either.

You do just need port 80 and 443 open. But on your system port 80 isn't open. There's something blocking connections from the Internet on that port. Maybe your firewall isn't configured the way you think it is; maybe it's something your ISP is doing; maybe it's only blocking some IP blocks or countries. But port 80 needs to be open to the world in order to do the HTTP-01 challenge.


Thank you very much. I just had to open port 80 on the firewall. Unfortunately, this was a blindspot of me because I also use this server as webproxy.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.