AttributeError: module 'acme.challenges' has no attribute 'TLSSNI01Response'

My domain is:

I ran this command:
sudo certbot renew

It produced this output:

Traceback (most recent call last):
File “/usr/bin/certbot”, line 11, in
load_entry_point(‘certbot==0.31.0’, ‘console_scripts’, ‘certbot’)()
File “/usr/local/lib/python3.5/dist-packages/pkg_resources/”, line 489, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File “/usr/local/lib/python3.5/dist-packages/pkg_resources/”, line 2793, in load_entry_point
return ep.load()
File “/usr/local/lib/python3.5/dist-packages/pkg_resources/”, line 2411, in load
return self.resolve()
File “/usr/local/lib/python3.5/dist-packages/pkg_resources/”, line 2417, in resolve
module = import(self.module_name, fromlist=[‘name’], level=0)
File “/usr/lib/python3/dist-packages/certbot/”, line 18, in
from certbot import account
File “/usr/lib/python3/dist-packages/certbot/”, line 21, in
from certbot import constants
File “/usr/lib/python3/dist-packages/certbot/”, line 53, in
AttributeError: module ‘acme.challenges’ has no attribute ‘TLSSNI01Response’

My web server is (include version):
The operating system my web server runs on is (include version):
ubuntu 16.04

1 Like

Please show all the relevant renewal config files in:

1 Like

Hi @ali94

I have no idea about that problem.

But there is another topic with the same problem:

Perhaps that helps.


For one thing, can you show us the output of “head /usr/bin/certbot”?

1 Like

Thnx, This is the output

1 Like

no such file or directory! i have this directory /etc/letsencrypt/
but it’s empty

1 Like

Thnx for your reply. i’ll check it

1 Like

Thank you.

What’s the output of “/usr/bin/python3 -c 'import acme; print(acme)'”?

<module ‘acme’ from ‘/usr/lib/python3/dist-packages/acme/’>

I’m confused, to be honest. One explanation for the error could be that you have a very new version of the acme module, but if so, where is it, and how did it get there?

Are all of your packages up-to-date? “apt update” and “apt list --upgradeable” doesn’t show that anything needs to be upgraded?

What does “dpkg -l python3-acme” show?

sorry but how can i tottaly delete certbot and start again?

Without knowing what happened, there’s no way to be sure how it happened, or how to stop it from happening again.

Hi All.

I’ve been trying to solve exactly the same problem. I was trying to add cerbot-dns-cloudflare to automate a wildcard renewal and am now getting the same error as ali94.

“0.31.0-1+ubuntu16.04.1+certbot+1” is installed but ‘certbot -v’ produces the acme.challenges module error from the original posting.
I’m also using nginx 1.10.3 and ubuntu 16.04.
/usr/bin/certbot output is identical to ali94’s.
acme module is from: <module ‘acme’ from ‘/usr/local/lib/python3.5/dist-packages/acme/’>

I have an existing (letsencrypt) wildcard certificate on the server (which I used to update manually) and a standard certificate which used to auto renew fine. However now I can’t update either manually or automatically.

It sounds like this was initially due to an incorrect update procedure or different versions of certbot being installed but I’ve now tried a lot of possible fixes and removed and reinstalled some packages a few times. At this point i’d also be happy to just remove all traces of certbot and start from scratch but just removing and reinstalling certbot doesn’t solve it.

Any help would be greatly appreciated!


p.s. dpkg -l python3-acme shows:

python3-acme 0.31.0-2+ubuntu1

and dpkg-query -l “certbot” shows:

ii certbot 0.31.0-1+ubuntu1 all automatically configure HTTPS using Let’s Encrypt
ii python-certbot-apache 0.31.0-1+ubuntu1 all transitional dummy package
un python-certbot-apache-d (no description available)
un python-certbot-doc (no description available)
ii python-certbot-nginx 0.31.0-1+ubuntu1 all transitional dummy package
un python-certbot-nginx-do (no description available)
ii python3-certbot 0.31.0-1+ubuntu1 all main library for certbot
ii python3-certbot-apache 0.31.0-1+ubuntu1 all Apache plugin for Certbot
ii python3-certbot-dns-clo 0.23.0-1ubuntu0p all Cloudflare DNS plugin for Certbot
ii python3-certbot-nginx 0.31.0-1+ubuntu1 all Nginx plugin for Certbot

(I installed the certbot-apache package due to a suggestion in another post, I was having the same problem before it was installed.)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.