Apache redirect HTTP to HTTPS after disable .conf generated by certbot-auto


#1

Hi,

I generated a certificate for a vhost with certbot-auto and it doesn’t work.

After that I disabled (a2dissite) the vhostname-le-ssl.conf and re-enabled the old configuration and restarting apache, but apache keeps redirecting all traffic from HTTP to HTTPS.

I’ve removed from sites-available but still redirecting.

I don’t know what to do, I’ve tried everything (certbot-auto rollback, rewrite my .conf and disable all other vhosts).


#2

Are you certain apache is actually still doing the redirect, or could this be due to browser caching? HTTP 301 redirects are typically cached pretty aggressively.

curl -i http://example.com would be a quick way to test that.


#3

pfg

Really aggressively! Its working after clean cache!

Thanks for the information!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.