Apache is not starting after I deleted ssl certificate from certbot

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.tomebox.in

I ran this command: sudo certbot delete

It produced this output: AH00526: Syntax error on line 20 of /etc/apache2/sites-enabled/000-default-le-ssl.conf: SSLCertificateFile: file '/etc/letsencrypt/live/tomebox.in/fullchain.pem' does not exist or is empty Action 'configtest' failed. The Apache error log may have more information

My web server is (include version): apache 2.4.29

The operating system my web server runs on is (include version): ubuntu 18.04.4

My hosting provider, if applicable, is: digitalocean

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 0.31.0

Please ask if any further details are needed, Any help is much appriciated.

Hi @ramadheer

if you do that

Apache is not starting after I deleted ssl certificate from certbot

without removing the file from your Apache config, the result is expected.

  • Disable that vHost (or)
  • change the file names, so a standard self signed certificate is used.

Never delete certificates that are used.

PS: Why isn't there a backup you can use? Never delete files if you don't have a backup (Rule no 1 using computers).

Hi @JuergenAuer thanks for reaching out. I am new to the world of server administration and was not knowing the possible outcomes my actions may have.
It would be really helpful for me if you can suggest me how I can disable that Vhost or change the file names.

1 Like

Use this command to disable it:
sudo a2dissite 000-default-le-ssl

1 Like

this command is giving the error: ERROR: Site 000-default-le-ssl does not exist!

Show the output of this command:

ls -l /etc/apache2/sites-enabled/

total 4
-rw-rw-r-- 1 www-data www-data 693 Oct 3 09:26 000-default.conf

I don't understand how apache is saying there is a problem in a conf file when it doesn't exist. Did you remove it?

Show the output of this command:

sudo apache2ctl configtest

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Syntax OK

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Syntax OK

yes I think i removed the config file

So the initial problem has gone once you removed the file.

I don't know what you want to do now but your site is redirecting http to https and you have removed the cert and the conf so you should fix that redirection.

yeah got it, thanks for the help buddy! :slight_smile:

2 Likes