Apache & "Error: The server could not connect to the client for DV"


#1

I cannot get let’s encrypt to work with my Debian server’s apache2 configuration.

I have tried:

./letsencrypt-auto --agree-dev-preview --server       https://acme-v01.api.letsencrypt.org/directory auth
./letsencrypt-auto --verbose --agree-dev-preview --server       https://acme-v01.api.letsencrypt.org/directory auth
./letsencrypt-auto --verbose --installer apache --standalone --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory auth
./letsencrypt-auto --verbose --installer apache --authenticator standalone --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory auth
./letsencrypt-auto --verbose --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory auth
./letsencrypt-auto --verbose --standalone --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory auth
./letsencrypt-auto --verbose --standalone --installer apache --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory auth
./letsencrypt-auto --verbose --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory auth
./letsencrypt-auto --verbose --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory
./letsencrypt-auto --verbose --apache --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory auth
./letsencrypt-auto --verbose --installer apache --standalone --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory auth

When I use the standalone variation (--installer apache --standalone), I successfully obtain and validate a certificate, but I have no idea where it is, nor is it automatically configured in the apache virtual host for the domain in question.

When I use --installer apache --authenticator standalone I get DV errors.

Before trying all this I ensured that when Apache is running I can talk to port 80 and 443 (just using telnet) and I was able to connect, so I don’t believe it’s a connectivity problem, but at this point I’m clueless (and very frustrated!).

The domain in question has the following Virtual Host configuration in /etc/apache2/sites-enabled/ (a symlink to sites-available of course):

<VirtualHost *:80>
    SSLEngine off 
    ServerAdmin atc@example.org
    ServerName example.org
    ServerAlias www.example.org
    Alias /blog "/usr/share/wordpress/"
    ErrorLog ${APACHE_LOG_DIR}/example.org-error.log
    CustomLog ${APACHE_LOG_DIR}/example.org-access.log combined
    DocumentRoot /var/www/example.org/www
</VirtualHost>

Please, can someone help me understand what the issue might be and how to rectify it?


#2

Hello, is anyone able to help me with my issue?

I’m basically stuck being able to associate my certificate with Apache2 and the virtual host I choose during letsencrypt-auto because even when I successfully obtain a certificate, it is not set up in my Apache virtual host.

Anyone able to help please? This is for the Let’s Encrypt Beta.


#3

I also have this problem. They tell me to check if my server is accessible on 443 from elsewhere on the Internet (or if you changed your DNS recently, that might be it).

My host is accessible and I have not changed my DNS. Not sure what’s up.