Android 4.x Download through HTTPS not possible


#1

Not sure where to post it…

It seems that downloading a file from a Letsencrypt-Secured Domain (https) is not possible because the downloader-application of android do not recognize the letsencrypt certificate.

I was able to reproduce the bug on three devices running all Android 4.2

The HTTPS-Certificate is properly setup and validated with various SSL Tests. When opening the link in Android, the browser recognizes the certificate.

I tried to deploy an .APK through my own Server through HTTPS, didn’t work. So I tried the diawi service (https://www.diawi.com)… same Problem. Both servers have in common that they use HTTPS-Certificates from Letsencrypt. When I try to download the app through normal unsecured HTTP, everthing works.

It seems that the Android Download-App does not recognize SSL-Certificates from letsencrypt.


#2

Did you test the domain with ssllabs.com ? Did ssllabs report “chain issues” ?


#3

No, no chain issues are reported.

The domain is https://data.ir-tech.ch if you want to test it as well.


#4

Does to code you use to download support SNI ?


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.