An unexpected error occurred: AttributeError: can't set attribute

My domain is: www.extra-ordinaire.com

I ran this command: I use webmin to produce the command

It produced this : (letsencrypt.log)


2024-03-27 06:54:00,231:DEBUG:certbot._internal.main:certbot version: 2.1.0
2024-03-27 06:54:00,231:DEBUG:certbot._internal.main:Location of certbot entry point: /bin/letsencrypt
2024-03-27 06:54:00,231:DEBUG:certbot._internal.main:Arguments: ['-a', 'webroot', '-d', 'extra-ordinaire.com', '-d', 'www.extra-ordinaire.com', '--webroot-path>
2024-03-27 06:54:00,231:DEBUG:certbot._internal.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#manual,PluginEntryPoint#null,PluginEntryPoint#standal>
2024-03-27 06:54:00,236:DEBUG:certbot._internal.log:Root logging level set at 30
2024-03-27 06:54:00,236:DEBUG:certbot._internal.plugins.selection:Requested authenticator webroot and installer None
2024-03-27 06:54:00,237:DEBUG:certbot._internal.plugins.selection:Single candidate plugin: * webroot
Description: Place files in webroot directory
Interfaces: Authenticator, Plugin
Entry point: webroot = certbot._internal.plugins.webroot:Authenticator
Initialized: <certbot._internal.plugins.webroot.Authenticator object at 0x7f26e4e34a50>
Prep: True
2024-03-27 06:54:00,237:DEBUG:certbot._internal.plugins.selection:Selected authenticator <certbot._internal.plugins.webroot.Authenticator object at 0x7f26e4e34>
2024-03-27 06:54:00,237:INFO:certbot._internal.plugins.selection:Plugins selected: Authenticator webroot, Installer None
2024-03-27 06:54:00,528:DEBUG:acme.client:Sending GET request to https://acme-v02.api.letsencrypt.org/directory.
2024-03-27 06:54:00,602:DEBUG:urllib3.connectionpool:Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org:443
2024-03-27 06:54:00,990:DEBUG:urllib3.connectionpool:https://acme-v02.api.letsencrypt.org:443 "GET /directory HTTP/1.1" 200 752
2024-03-27 06:54:00,991:DEBUG:acme.client:Received response:
HTTP 200
Server: nginx
Date: Wed, 27 Mar 2024 06:54:00 GMT
Content-Type: application/json
Content-Length: 752
Connection: keep-alive
Cache-Control: public, max-age=0, no-cache
X-Frame-Options: DENY
Strict-Transport-Security: max-age=604800

{
  "2M4VtS7wAfY": "https://community.letsencrypt.org/t/adding-random-entries-to-the-directory/33417",
  "keyChange": "https://acme-v02.api.letsencrypt.org/acme/key-change",
  "meta": {
    "caaIdentities": [
      "letsencrypt.org"
    ],
    "termsOfService": "https://letsencrypt.org/documents/LE-SA-v1.3-September-21-2022.pdf",
    "website": "https://letsencrypt.org"
  },
  "newAccount": "https://acme-v02.api.letsencrypt.org/acme/new-acct",
  "newNonce": "https://acme-v02.api.letsencrypt.org/acme/new-nonce",
  "newOrder": "https://acme-v02.api.letsencrypt.org/acme/new-order",
  "renewalInfo": "https://acme-v02.api.letsencrypt.org/draft-ietf-acme-ari-02/renewalInfo/",
  "revokeCert": "https://acme-v02.api.letsencrypt.org/acme/revoke-cert"
}

My web server is (include version): Apache version 2.4.57

The operating system my web server runs on is (include version): debian 12

I can login to a root shell on my machine

I'm using a control panel to manage my site : webmin

The version of my client is (e.g. output of certbot --version ): certbot 2.1.0 but not using it directly, as i try with the control panel

It is a fresh install on a new server, only retore the domain on this new server
What to check, do ?

Please upgrade your Certbot to at least 2.3.0, which is the version in which this error was fixed.

Debian is notoriously slow and lagging with regard to software updates. Please use snap to install Certbot as recommended on Certbot Instructions | Certbot.

3 Likes

Thanks I do all this stuff, and website is now under SSL, but I still have a trouble:

Failed redirect for extra-ordinaire.com
Unable to set the redirect enhancement for extra-ordinaire.com.
Unable to find corresponding HTTP vhost; Unable to create one as intended addresses conflict; Current configuration does not support automated redirection

My cerbot version si now 2.9.0

1 Like

Your Apache version probably doesn't include a virtualhost (alias) for extra-ordinaire.com.

Please show the output of

sudo apachectl -t -D DUMP_VHOSTS

if you don't know directly how to add it yourself.

3 Likes