AH00526: Syntax error on line 1 of /etc/apache2/other/le_http_01_challenge_pre.conf:


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: parkour.creativetechs.com

I ran this command: sudo certbot --apache

It produced this output: AH00526: Syntax error on line 1 of /etc/apache2/other/le_http_01_challenge_pre.conf:
Invalid command ‘RewriteEngine’, perhaps misspelled or defined by a module not included in the server configuration

My web server is (include version): Apache2

The operating system my web server runs on is (include version): MacOS10.12

My hosting provider, if applicable, is: Self Hosted

I can login to a root shell on my machine (yes or no, or I don’t know): Y

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): N

Hey there when I run sudo certbot --apache I get the above error. Any thoughts on what to look for or fix? Is it a permissions error? Only other clue I can provide is that on my first run it stopped because I didn’t have any virtual hosts so I added one - could I have misconfigured that?

Thanks in advance.


#2

Edit your /etc/apache2/httpd.conf file, find this line, and remove the # at the beginning to uncomment and activate it:

LoadModule rewrite_module libexec/apache2/mod_rewrite.so

Restart Apache and then try running certbot again.

@joohoi maybe certbot could enable mod_rewrite automatically if it isn’t already enabled?


#3

Awesome! Thanks! Now I got one more error, but think its easily solvable. Can you tell me is this in regards to the internal IP or External IP and the DNS records, is that the public ones or something the machine is picking up?

The following errors were reported by the server:

Domain: parkour.creativetechs.com
Type: unauthorized
Detail: Invalid response from
http://parkour.creativetechs.com/.well-known/acme-challenge/3UqqhpycBtNbOlt7HdUUeLjmRbllqnEaL57ssv4m5vE:
"

404 Not Found

Not Found

<p"

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address.

Thanks


#4

It seems to be a Mac Apache server listening on the outside IP address.

I guess the Mac calendar server takes over the /.well-known directory of the server also used by Let’s Encrypt. There’s a workaround described here:


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.