After enabling Letsencrypt certificate, not able to access my website from browser(This site can’t be reached)

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: uwaysoftware.com

I ran this command:
sudo yum install snapd
sudo systemctl enable --now snapd.socket
sudo snap install core; sudo snap refresh core;
sudo ln -s /var/lib/snapd/snap /snap
sudo snap install --classic certbot
sudo ln -s /snap/bin/certbot /usr/bin/certbot
sudo certbot --apache

It produced this output: Congratulations! You have successfully enabled https://uwaysoftware.com

My web server is (include version): apache (wordpress platform) and domain is from Godaddy

The operating system my web server runs on is (include version): Oracle Linux 7.8

My hosting provider, if applicable, is: Oracle Cloud

I can login to a root shell on my machine (yes or no, or I don't know):Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.10.1

Kindly support immediately, my website is down for more than 10 hours.

2 Likes

You need to open port 443 to allow HTTPS to work.

2 Likes

Hi,
443 port is opened but still getting same error. see the below traces:

[opc@uwayinstance1-380831 conf]$ curl -v telnet://uwayinstance1-380831:443

  • About to connect() to uwayinstance1-380831 port 443 (#0)
  • Trying 10.0.2.9...
  • Connected to uwayinstance1-380831 (10.0.2.9) port 443 (#0)
2 Likes

That shows port 443 is listening. And can be connected to locally (IP 10.0.2.9).
It doesn't show that the Internet can reach it via port 443.
Is there a firewall?

I get:

curl -Iki https://uwaysoftware.com/
curl: (7) Failed to connect to uwaysoftware.com port 443: Connection timed out
AND
curl -Iki https://uwaysoftware.com/
curl: (7) Failed to connect to uwaysoftware.com port 443: No route to host
3 Likes

Yes there was firewall . thanks a lot for pointer.

I run below command and then it works fine:
sudo firewall-cmd –-permanent –-zone=public –-add-port=443/tcp

3 Likes

I'm glad you were able to solve your own problem.

Cheers from Miami :beers:

2 Likes