ACMEv1 Support - Update your client software to continue using Let's Encryp

Hi All

We have a Mitel server that utilises Lets Encrypt, we recently received an email stating that…

Beginning June 1, 2020, we will stop allowing new domains to validate using the ACMEv1 protocol. You should upgrade to an ACMEv2 compatible client before then, or certificate issuance will fail. For most people, simply upgrading to the latest version of your existing client will suffice. You can view the client list at: https://letsencrypt.org/docs/client-options/

There is a patch available on the Mitel server to make it compatible with ACMEv2 but we not be able to apply this before June 1st.

My question is, because this is an existing domain (it has been using LetsEncrypt since 2018) what are the implications come June 1st? Do we have more time to get the patch applied post June the 1st?

Hope that makes sense.

Thanks

1 Like

Hi @pbxsupport

what’s your domain name?

Check the certificate, perhaps renew it before 2020-06-01. After renewing you have 90 days to update your configuration.

2 Likes

The domain name is

I have checked the certificate and it renewed on May 10th so it is valid till Aug 8th.

Thanks

3 Likes

Yep, that looks good. Enough time to update your configuration. :+1:

2 Likes

Thanks for your assistance.

1 Like

Can the domain name be removed from this post? Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.