Aborting bootstrap?

I ran this command as root on patched and updated CentOS 6.10 :

cd /root/letsencrypt/ && ./letsencrypt-auto renew

It produced this output:

Upgrading certbot-auto 1.0.0 to 1.1.0…
Replacing certbot-auto…
Bootstrapping dependencies for Legacy RedHat-based OSes that will use Python3… (you can skip this with --no-bootstrap)
yum is hashed (/usr/bin/yum)
To use Certbot on this operating system, packages from the SCL repository need to be installed.
Enabling the SCL repository in 3 seconds… (Press Ctrl-C to cancel)e[0KEnabling the SCL repository in 2 seconds… (Press Ctrl-C to cancel)e[0KEnabling the SCL repository in 1 second… (Press Ctrl-C to cancel)
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile

  • base: mirror.ventraip.net.au
  • epel: mirror.realcompute.io
  • extras: mirror.ventraip.net.au
  • updates: mirror.colocity.com
    No package available.
    Package 10:centos-release-scl-7-4.el6.centos.noarch already installed and latest version
    Nothing to do
    No supported Python package available to install. Aborting bootstrap!

Any tips or clues for how to fix ? Current cert expires in a few weeks.

1 Like

I think it’d be easier to use different acme client that has less dependency, like acme.sh


Still, certbot-auto should work.

The release notes said that “certbot-auto no longer supports architectures other than x86_64 on RHEL 6 based systems”, but it shouldn’t stop working.

1 Like

What is the output of the uname -i command? If the output is i386, than I suggest to use a different tool to get certificate. (I guess, that architecture is not supported any more by the latest python language.)
List of software to get a certificate: https://letsencrypt.org/docs/client-options/

1 Like

@bgroper, on x86-64 RHEL 6 based systems, certbot-auto is trying to enable the SCL repository so it can install a version of Python that is still supported by the Python maintainers. Usually this can be done by installing the centos-release-scl package, but this doesn’t appear to be working on your system.

Do you know why? Have you manually disabled SCL? You can see which repositories are enabled by running a command like sudo yum repolist. You may be able to fix the problem by uninstalling and reinstalling the centos-release-scl package and its dependency through commands like:

sudo yum remove centos-release-scl-rh centos-release-scl
sudo yum install centos-release-scl

If none of this helps you resolve the problem, what is the output of sudo yum repolist and sudo tail -n +1 /etc/yum.repos.d/*SCL*


Thanks to bmw for good instructions.
Seems to be fixed now.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.