500 - Internal server error issues since updating certs for another domain

So I added some new certs to another domain(DNS is hosted at the same place for both domains) which you can see here:

Trouble installing previously obtained certificate

Since then, I have noticed my other domain(downundercruiseanddive.com.au) is getting 500 Internal Server Error on certain pages. (index, terms etc) Some pages work fine. Not 100% sure this is lets encrypt related, but the issue arose right after I updated my certs for my other domain…

My domain is: downundercruiseanddive.com.au

My web server is (include version): IIS

The operating system my web server runs on is (include version): Win Server 2016 64bit

My hosting provider, if applicable, is: self hosted, on site.

I can login to a root shell on my machine (yes or no, or I don’t know): Not sure.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): I log directly into the windows machine…

Just dug a bit further in, seems like the 500 error is
0x80070102
C:\Program Files (x86)\PHP\v5.6\php-cgi.exe - The FastCGI process exceeded configured request timeout

Could this be related to lets encrypt or not likely?

It sounds like your PHP website is timing out for the usual reasons (slow server, something wrong in the code, etc). The FastCGI timeout is the biggest evidence of that.

SSL operates at an earlier/higher different layer to your web application. We know that the SSL is probably functioning OK because, as you mention, if we visit your about page, it loads instantly. A problem with SSL wouldn’t be selective like that.

1 Like

Ahhh very true, thank you.

I shall look elsewhere for how to solve this. Perhaps IIS forums…

But cheers, appreciate the help!

I wonder why it only times out on some pages and not others tho … :frowning:

This request timeout is most like when it’s querying a database, and the usual fix for that is to re-index the database tables (or perform other routine maintenance), that would also explain why it only times out on certain pages (if only certain pages query the database that way).

As an aside, your website is about 14MB of data for one page, which for some users will be a real crawl (especially internationally). I’d get someone to spend a few hours just optimising it . e.g. about page loads an 8MB image: https://downundercruiseanddive.com.au/shared/img/upper-deck-interior-evolution-boat.jpg

…and while they’re there they could check out the timeouts

1 Like

Hmmmm, no idea how to do that - but I think you’re right…

everything I read is just telling me to increase the timeout allowance, but that won’t fix the root cause imho…

But this answer it helpful and has given me direction, thank you sir!

Hmm after more digging, I don’t think it is my database; many pages that rely on data form there are still loading quickly…

One page that was working, I edited the php(literally moved a div position) and now that page hits the same error. Its like when I save a file its changing ownership and preventing the IIS user from being able to read it… I think.

More digging to do…

Thank you for the help though my friend - lets encrypt is my favorite community now. Excellent group.

Ok, I’d check the windows Event Log as there may be more exception details under Application. I’m not a php expert but have used it a reasonable amount in the past, you probably need to look into switching on a debug mode and logging, and I’d suggest tinkering with a copy of the site rather than the live one (not sure if you are or not!). Making a minor changing to a file and it causing a new error would suggest some kind of php caching issue and as you say php would need permission to write to wherever it’s storing it’s cache.

1 Like

LOL - I restarted the server and it fixed everything…

Not sure what the heck went wrong.

In anycase, I really appreciate the help… Thank you so much!

Weird (well, not really!) glad it worked out ok.

1 Like

Yeah, guessed I forgot the old IT axiom - ‘have you tried turning it off and on again’ !!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.