404 on all Wordpress pages except home and admin pages

Hi I looked throughout the related posts and worked couple days to solve this but still in vain. Can anyone know how to solve this? It worked prefect with https on home and admin pages but not working for the rest. I dont know where to try. Please kindly advice. Thanks so much!

Please fill out the fields below so we can help you better.

My domain is:ssl2.wooshop.com.tw

I ran this command: I installed LE by using Certbot.

It produced this output:
We were unable to find a vhost with a ServerName or Address of ssl2.wooshop.com.tw.
Which virtual host would you like to choose?
(note: conf files with multiple vhosts are not yet supported)
1: wordpress.conf | | | Enabled
2: default-ssl.conf | | HTTPS |
3: 000-default.conf | | |
Select the appropriate number [1-3] then [enter] (press ‘c’ to cancel): 2
Enabled Apache socache_shmcb module
Enabled Apache ssl module
Deploying Certificate to VirtualHost /etc/apache2/sites-available/default-ssl.conf
Enabling available site: /etc/apache2/sites-available/default-ssl.conf

Please choose whether HTTPS access is required or optional.
1: Easy - Allow both HTTP and HTTPS access to these sites
2: Secure - Make all requests redirect to secure HTTPS access
Select the appropriate number [1-2] then [enter] (press 'c' to cancel): 1

Congratulations! You have successfully enabled https://ssl2.wooshop.com.tw

You should test your configuration at:

My web server is (include version):
**Operating System **
Debian 8
**Software **
Apache HTTP Server (2.4.10)
MySQL (5.5.46)
PHP (5.6.14)

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: GCP

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

Is the vhost defined in default-ssl.conf also serving the WordPress install and have you configured mod_rewrite rules for that vhost or .htaccess file?
One other thing to check is if AllowOverride directive in default-ssl.conf allows overrides in the .htaccess file inside WordPress directory.

1 Like

@AndyShmandy Apologized for my late reply. The notification email went straight to my spam box. I tried other method to install SSL and it works now. I will go back to check if I got the same issue again. Thanks so much for your help! :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.