Www domain http-01 challenged failed

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: xilux-global.com

I ran this command:
sudo certbot --nginx --agree-tos --no-eff-email --keep --redirect
-m my_email -d xilux-global.com -d www.xilux-global.com

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for www.xilux-global.com
nginx: [warn] "ssl_stapling" ignored, issuer certificate not found for certificate "/etc/ssl/certs/ssl-cert-snakeoil.pem"
nginx: [warn] "ssl_stapling" ignored, issuer certificate not found for certificate "/etc/ssl/certs/ssl-cert-snakeoil.pem"
Waiting for verification...
Challenge failed for domain www.xilux-global.com
http-01 challenge for www.xilux-global.com
Cleaning up challenges
nginx: [warn] "ssl_stapling" ignored, issuer certificate not found for certificate "/etc/ssl/certs/ssl-cert-snakeoil.pem"
Some challenges have failed.


  • The following errors were reported by the server:

    Domain: www.xilux-global.com
    Type: connection
    Detail: Fetching
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you're using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):
nginx 1.18.0
The operating system my web server runs on is (include version):
Ubuntu 20.04
My hosting provider, if applicable, is:
I can login to a root shell on my machine (yes or no, or I don't know):
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 0.40.0

certbot works with the non-www version of my website, but not www.xilux-global.com. I got my domain from namecheap, I made an A record point to ipv4, AAAA record point to ipv6.

There is a NameCheap redirect in place from HTTP to HTTPS, but the NameCheap IP address (IPv4, IPv6 is broken horribly) isn't open for port 443.

Do you actually require that NameCheap URL redirect? Can't you just point the hostname(s) directly to your server?


It sounds like you might have left a checkbox on for NameCheap to do a redirection you no longer need.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.