Wrong certificate

My domain is:
discord.vreecoaster.de
vreecoaster.de
teccio.de

I ran this command:
certbot --nginx -d DOMAIN

It produced this output:
https://just-paste.it/vkW82Mi3vw
The domain vreecoaster.de and the subdomain discord.vreecoaster.de take the certificate of teccio.de
untrust source.
and the index.php get downloaded.

My web server is (include version):
nginx/1.14.2

The operating system my web server runs on is (include version):
Debian 10 Backports

I can login to a root shell on my machine (yes or no, or I don't know):
yes
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
no

1 Like

I renewed certificates. Still untrust source. With discord.vreecoaster.de and vreecoaster.de I get to the site teccio.de and if I want to go to teccio.de a file gets downloaded of the index.php.

1 Like

Hi @crafter2345

that's your configuration. But your configuration is buggy, so it's not that what nginx sees.

What says

nginx -T

Please share the output as text in this forum.

3 Likes

https://just-paste.it/KGIeb3W6Xt

you have a solution for the big problem?

Hello @crafter2345,

You are using port 444 in your https connection for domain vreecoaster.de and port 445 for discord.vreecoaster.de and you should use port 443 for both.

An example, use below url and you will access your site correctly:

https://vreecoaster.de:444

Cheers,
sahsanu

1 Like

nginx: [emerg] duplicate listen options for [::]:443 in /etc/nginx/sites-enabled/default:223
When I reload nginx
https://just-paste.it/IRiE26mgvq

1 Like

You can only specify parameter ipv6only=on once in a listen directive so, keep the first one and remove the other ones.

1 Like

If I join teccio.de the index.php get downloaded

Sorry but when I try to access your site I see this:

1 Like

In inkognito mode I can join, I deleted cache and cookies but the index.php get downloaded on join
EDIT: It works now, don't know why. Very thanks for your help, I really appreciate it!

2 Likes

not sure why issues popped up, mind you I use a clean install of linux for anything so that if config file are trash it's not that hard to fix

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.