# Wildcard Renewal Error

**URL:** https://community.letsencrypt.org/t/wildcard-renewal-error/66062
**Category:** Help
**Created:** [July 6, 2018, 1:01am UTC](https://community.letsencrypt.org/t/wildcard-renewal-error/66062 "2018-07-06T01:01:24Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![pbr18](https://avatars.discourse-cdn.com/v4/letter/p/8491ac/32.png) [@pbr18](https://community.letsencrypt.org/u/pbr18)
#### Post date: [July 6, 2018, 1:01am UTC](https://community.letsencrypt.org/t/wildcard-renewal-error/66062/1 "2018-07-06T01:01:24Z")

</div>

Hi,

My domain is:vhost.fr

I ran this command:certbot renew

It produced this output:  
[root@dns]# certbot renew  
Saving debug log to /var/log/letsencrypt/letsencrypt.log

* * *

## Processing /etc/letsencrypt/renewal/vhost.fr.conf

Cert is due for renewal, auto-renewing…  
Plugins selected: Authenticator dns-rfc2136, Installer None  
Starting new HTTPS connection (1): [acme-v02.api.letsencrypt.org](http://acme-v02.api.letsencrypt.org)  
Renewing an existing certificate  
Performing the following challenges:  
dns-01 challenge for [vhost.fr](http://vhost.fr)  
dns-01 challenge for [vhost.fr](http://vhost.fr)  
Cleaning up challenges  
Attempting to renew cert ([vhost.fr](http://vhost.fr)) from /etc/letsencrypt/renewal/vhost.fr.conf produced an unexpected error: Received response from server: SERVFAIL. Skipping.  
All renewal attempts failed. The following certs could not be renewed:  
/etc/letsencrypt/live/vhost.fr/fullchain.pem (failure)

* * *

## All renewal attempts failed. The following certs could not be renewed: /etc/letsencrypt/live/vhost.fr/fullchain.pem (failure)

1 renew failure(s), 0 parse failure(s)

My server is (include version): CentOS 7.5 (bind 9.9.4)

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: my

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

I ran this command:certbot certificates  
It produced this output:  
[root@dns]# certbot certificates  
Saving debug log to /var/log/letsencrypt/letsencrypt.log

* * *

## Found the following certs: Certificate Name: [vhost.fr](http://vhost.fr) Domains: \*.vhost.fr [vhost.fr](http://vhost.fr) Expiry Date: 2018-07-12 18:15:51+00:00 (VALID: 6 days) Certificate Path: /etc/letsencrypt/live/vhost.fr/fullchain.pem Private Key Path: /etc/letsencrypt/live/vhost.fr/privkey.pem

---

<div class="post-metadata">

### Author: ![\_az](https://avatars.discourse-cdn.com/v4/letter/_/22d042/32.png) [@\_az](https://community.letsencrypt.org/u/_az)
#### Post date: [July 6, 2018, 1:11am UTC](https://community.letsencrypt.org/t/wildcard-renewal-error/66062/2 "2018-07-06T01:11:53Z")

</div>

> [@pbr18](#):
>
> Received response from server: SERVFAIL

The nsupdate failed. Go check your BIND (or whatever nameserver you are using) logs.

It's probably the same cause as last time you had this issue: [SERVFAIL - Wildcard DNS01 Bind](https://community.letsencrypt.org/t/servfail-wildcard-dns01-bind/59340)

---

<div class="post-metadata">

### Author: ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)
#### Post date: [July 6, 2018, 2:56am UTC](https://community.letsencrypt.org/t/wildcard-renewal-error/66062/3 "2018-07-06T02:56:01Z")

</div>

The IPv6 address is failing…

Name: [vhost.fr](http://vhost.fr)  
Addresses: 2a01:cb00:817a:8b00:7e03:d8ff:fea9:4f24  
86.196.133.135

LE prefers IPv6 and will not use IPv4 when IPv6 exists.

---

<div class="post-metadata">

### Author: ![pbr18](https://avatars.discourse-cdn.com/v4/letter/p/8491ac/32.png) [@pbr18](https://community.letsencrypt.org/u/pbr18)
#### Post date: [July 6, 2018, 9:51am UTC](https://community.letsencrypt.org/t/wildcard-renewal-error/66062/4 "2018-07-06T09:51:26Z")

</div>

Hi,

My problem seems different. There is no error on the file rights in the logs.  
The trouble seems to come from the file /etc/letsencrypt/reneval/vhost.fr.conf which causes an unexpected error.

The letsencrypt.log file contains:  
DEBUG: requests.packages.urllib3.connectionpool: “HEAD /acme/new-order HTTP/1.1” 405 0  
HTTP 405  
…  
content-type: application/problem+json

and

DEBUG:certbot.error\_handler:Encountered exception :  
File “…/auth\_handler.py”, line 75, in handle\_authorizations  
resp = self.\_solve\_challenges(aauthzrs)  
…

---

<div class="post-metadata">

### Author: ![\_az](https://avatars.discourse-cdn.com/v4/letter/_/22d042/32.png) [@\_az](https://community.letsencrypt.org/u/_az)
#### Post date: [July 6, 2018, 9:54am UTC](https://community.letsencrypt.org/t/wildcard-renewal-error/66062/5 "2018-07-06T09:54:05Z")

</div>

I don’t think so. The original error you pasted is very clear that the nsupdate is the cause of the failure.

I’m not sure what this `HEAD` error is about when looking at it out of context. If you can post the full log, it would be clearer.

---

<div class="post-metadata">

### Author: ![pbr18](https://avatars.discourse-cdn.com/v4/letter/p/8491ac/32.png) [@pbr18](https://community.letsencrypt.org/u/pbr18)
#### Post date: [July 6, 2018, 12:17pm UTC](https://community.letsencrypt.org/t/wildcard-renewal-error/66062/6 "2018-07-06T12:17:55Z")

</div>

Hello,

You were right. I am very sorry. It is a problem of right on the directory /var /named/ which makes that the file .jnl can not be created.

It is all good. My certificate has been renewed.

Thank you very much.

---

<div class="post-metadata">

### Author: ![system](https://global.discourse-cdn.com/letsencrypt/original/3X/c/a/ca6c06ea1ea201324bba7048c6841ce60236468d.png) [@system](https://community.letsencrypt.org/u/system)
#### Post date: [August 5, 2018, 12:31pm UTC](https://community.letsencrypt.org/t/wildcard-renewal-error/66062/7 "2018-08-05T12:31:55Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
