Wildcard cert will not renew --dnssleep arg won't work

That log says you used the option --dns dns_yandex which would be the old plugin, not the new one using the yandex360 plugin.

@Neilpang Can you confirm that the value provided by the --dns option uses the file name of that value? I didn't find anything resembling like that file foobar.sh could provide a plugin for --dns baz for example. The correct value for the --dns option for the file foobar.sh in the dnsapi directory would be --dns foobar, right?


They provided this link and I created an app and now I am confused how to get a token and which one out of the 4 they decsribe

I can't figure out how to get a new token and which one should I get? This is what I was advised on a github anyway:

    • Yandex DNS API name has been changed. The new value for the --dns argument must now be set as dns_yandex360.
    • You must issue a new token for the updated Yandex API. Please refer to this guide for more information:Доступ к API - 360 API. api360
      and you also advised to fix the DNS API Test

Yes. it's the file name.


So can someone help with these 2 final steps ?

I don't think there's much Yandex experience on this Community I'm afraid.


It seems that way unfortunately - I guess I will need to switch to Cloudfare

Maybe there are support forums for Yandex?


I'll check it out first of course - my
cert expired today

Doesn't Yandex at least provide some manual TXT adding and removing in the mean time, while you're figuring out the API stuff?


No clue- everything changed very recently - I have to look into it

I may need to open another thread for changing Yandex api to Yandex360 and see if someone can help. Otherwise I will have to go with Cloudfare so not to deal with all this nonsense

Sounds great! You'd probably be working fine already had you done that 13 days ago when you first mentioned it :slight_smile:


Well I explained the only reason I hadn't done it - 5 mailboxes with my domain names on their servers. It is rather convenient and I am still thinking of salvaging this issue somehow. There gotta be people out there who dealt with it at least those who I see on the Github reporting it works for them. And on top of that I lost access to web GUI of the server because of the cert

1 Like

I replaced it but still get an error - I am stuck on getting a new token

You replaced "it" (what exactly?) but still get "an error" (which exactly?). Please try to provide as much information in your post as necessary. It's very frustrating for volunteers if they require to reconstruct a post with just a few vague words.


It was an answer to @Neilpang explaining that I replaced dns_yandex with a new script dns_yandex360 and now I need to get a new token too

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.