Why does my SSL website come out 404 error?


I set up SSL https: but I cant access my sites
I always face 404 error when I access them

I dont know why and what’s happening
what did I go wrong?
Can someone help me to fix it?
my sites are backlink chat luong and kinh doanh online


Does this 404 show up on all URLs on the site, or is the main page okay? Based on just the image, it looks like you might have a configuration issue where the site is configured differently with SSL versus without. A lot of how to fix that will depend on how you manage the server.


Are you really using Let’s Encrypt? Both sites say that CN is “localhost” and the OU is “none”. And one of the websites, after passing the error, says
"Apache is functioning normally"

You should remove and recreate the certificates. Are you using certbot? If not, use it, supposing you have root access in that server


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.