Where should vhosts file be?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
certbox --apache -d cirs.fyellin.com

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Could not find ssl_module; not disabling session tickets.
Plugins selected: Authenticator apache, Installer apache
Requesting a certificate for cirs.fyellin.com
Performing the following challenges:
http-01 challenge for cirs.fyellin.com
Cleaning up challenges
Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add
a virtual host for port 80.

My web server is (include version):

The operating system my web server runs on is (include version):
MacOs 11.1

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.14.0

I have modified the default httpd.conf by uncommenting:
Include /private/etc/apache2/extra/httpd-vhosts.conf

Inside http-vhosts.conf, I now have the following. Note that for now, I'm only trying to make a certificate for one of these. http:// to these web sites works fine. I get the same error even when I delete everything from the file except for cirs.fyellin.com

<VirtualHost *:80>
ServerName cirs.forward-scatter.com
DocumentRoot "/Library/WebServer/Documents"

<VirtualHost *:80>
ServerName cirs.forwardscatter.com
DocumentRoot "/Library/WebServer/Documents"

<VirtualHost *:80>
ServerName cirs.fyellin.com
DocumentRoot "/Library/WebServer/Documents"

What does the output of sudo apachectl -S say? That would help confirm that Apache can see your virtual hosts even though certbot can't.

My husband convinced me that I should be using HomeBrew Apache instead of the built in Apache. That seems to fix the problem.

So consider this closed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.