# What's the Let's Encrypt URL?

**URL:** <https://community.letsencrypt.org/t/whats-the-lets-encrypt-url/144562>\
**Category:** Issuance Tech\
**Created:** [February 5, 2021, 1:54am UTC](https://community.letsencrypt.org/t/whats-the-lets-encrypt-url/144562 "2021-02-05T01:54:22Z")\
**Posts on this page:** 4\
**Page:** 3

<div class="post-metadata">

**Author:** ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)\
**Post date:** [February 7, 2021, 2:37pm UTC](https://community.letsencrypt.org/t/whats-the-lets-encrypt-url/144562/41 "2021-02-07T14:37:35Z")

</div>

> [@bruncsak](#):
>
> Directories could have references to other directories.

In that case I would urge to call the meta-directory something different than "directory" 😉

Also, that would mean a addendum to the ACME protocol would need to be written and that probably would mean a different RFC et cetera.

---

<div class="post-metadata">

**Author:** ![griffin](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/griffin/32/50204_2.png) [@griffin](https://community.letsencrypt.org/u/griffin)\
**Post date:** [February 7, 2021, 6:15pm UTC](https://community.letsencrypt.org/t/whats-the-lets-encrypt-url/144562/42 "2021-02-07T18:15:47Z")

</div>

> [@Osiris](#):
>
> In that case I would urge to call the meta-directory something different than "directory" 😉

You mean something like "index"? 😉

> [@What's the Let's Encrypt URL?](https://community.letsencrypt.org/t/whats-the-lets-encrypt-url/144562/21):
>
> I…

---

<div class="post-metadata">

**Author:** ![jsha](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/jsha/32/12_2.png) [@jsha](https://community.letsencrypt.org/u/jsha)\
**Post date:** [February 7, 2021, 7:09pm UTC](https://community.letsencrypt.org/t/whats-the-lets-encrypt-url/144562/43 "2021-02-07T19:09:06Z")

</div>

> [@Osiris](#):
>
> Did someone forget to add a "version" field to the directory or was that left out intentionally?

Somewhat intentionally. There was some strong discussion on the ACME mailing list as we approached finalization of the spec. Some folks (like me) wanted to call the finalized version of the spec "ACMEv2." More experienced IETF folks said "there's no ACMEv1 and ACMEv2; there are just draft versions of ACME, and ACME (i.e. what became RFC 8555)." From a purely pragmatic standpoint, Let's Encrypt's acme-v02 endpoint implements RFC 8555, and acme-v01 endpoint implements something that is close to a variety of draft versions; the main separation is the move from new-authz / new-cert to new-order / finalize.

#### Directory URLs

By the way, some folks were talking earlier in this thread about the niceness of ACME being configured by a single directory URL that has links to all the different endpoints. There's another way to solve this problem, [exemplified by CT](https://tools.ietf.org/html/rfc6962). Logs are configured by a root URL, and all endpoints are at known fixed paths relative to that.

For instance, if a log URL is `https://example.com/mylog`, you know to send add-chain requests to `https://example.com/mylog/ct/v1/add-chain`. You also know to set get-entries requests to `https://example.com/mylog/ct/v1/get-entries`. I like this style of API design, but there was a document in the IETF, BCP 190 (aka [RFC 7320](https://tools.ietf.org/html/rfc7320)), that has long been interpreted to forbid it (BCP stands for Best Common Practice).

Anyhow, this issue came up during work on CT v2. The CT authors were asked to switch to a directory style like ACME, or a templating style like some other RFCs. I made a case that the common interpretation of RFC 7320 was too restrictive, and managed to convince folks! Mark Nottingham, the original author, did some revisions and made [RFC 8820](https://tools.ietf.org/html/rfc8820). That became the [_new_ BCP 190](https://tools.ietf.org/html/bcp190), and CT-style APIs are now allowed!

BCP 190 is dead, long live BCP 190!

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/letsencrypt/original/3X/c/a/ca6c06ea1ea201324bba7048c6841ce60236468d.png) [@system](https://community.letsencrypt.org/u/system)\
**Post date:** [March 10, 2021, 8:41pm UTC](https://community.letsencrypt.org/t/whats-the-lets-encrypt-url/144562/45 "2021-03-10T20:41:19Z")

</div>

Closed on March 10, 2021, 8:41pm UTC

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

[Previous page](https://community.letsencrypt.org/t/whats-the-lets-encrypt-url/144562.md?page=2)
