What is the right firewall configuration using Virtualmin


#1

Hi, I am trying Let’s Encrypt for the first time via Virtualmin. But the development website which is using woocommerce has some error with the payment gateway. They asked me to whitelist their IP address and I added it but still has an unknown error. They suspect it’s the SSL cert that’s causing this.

Is it the firewall thing that I misconfigure?

Thanks for your help.

Please fill out the fields below so we can help you better.

My domain is: https://jajananindo.com
I ran this command: Woocommerce check out page
It produced this output: Invalid response
My operating system is (include version): Ubuntu 16.04
My web server is (include version): PHP 7.0
My hosting provider, if applicable, is: Vultr
I can login to a root shell on my machine (yes or no, or I don’t know): yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Virtualmin


#2

You’re SSL cert looks to be installed and working correctly from what I can see, so I don’t think it would be that causing the error. Did woocommerce provide any more detailed info other than “They suspect it’s the SSL cert that’s causing this.”? something more specific would be useful.

likewise “an unknown error” is a bit tricky to help with. can you provide as much information as possible, assuming we know nothing, about this error. Those who use woocommerce may know what the command “Woocommerce check out page” is, but I have no knowledge of this.

i.e. exactly what is the “development website”, exactly what are you doing when you get the error ( adding something to the cart ? making a payment ? … ). What exactly is the error ? (a blank page, you get a specific message … ) What is in the system logs at that time ?


#3

the issue that’s raised by the payment gateway is that the SSL cert that I’m using is blocking POST request to their server.

the comparison test was made using a Comodo issue SSL cert on another Woocomerce site which worked.
another test was made when no https Woocomerce site, which also worked.

Unfortunately, Vultr my hosting provider is not helpful at all :frowning:


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.