Well known not found

My domain is:
smtp.bluedental.pl

I ran this command:
certbot certonly --webroot -w /etc/nginx/token/ -d smtp.bluedental.pl

It produced this output:
Failed authorization procedure. smtp.bluedental.pl (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://smtp.bluedental.pl/.well-known/acme-challenge/E0_ZTaN9YfripH2CF8zihBqmNd6N8n-X-PF9iBvRnZQ [37.190.144.15]: “\r\n404 Not Found\r\n<body bgcolor=“white”>\r\n

404 Not Found

\r\n

The operating system my web server runs on is (include version):
Debian GNU/Linux 9 (stretch)

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 0.28.0

dig smtp.bluedental.pl:
shows proper ip

nginx conf:
server {
listen 80;
server_name smtp.bluedental.pl sss.bluedental.pl;

location / {
root /etc/nginx/token/;
}
}

1 Like

That all looks correct.

Are you certain the IP address is correct?

What does Nginx’s error.log show?

If you check the Nginx configuration with “nginx -T”, is the virtual host enabled? Could there be another conflicting one?

1 Like

Are you certain the IP address is correct?

Yes I am. 37.190.144.15

What does Nginx’s error.log show?

It’s weird. Nothing.

Is the virtual host enabled?

After nginx -T I don’t see smtp.bluedental.pl virtual host configuration.

Could there be another conflicting one?

I wrote some bind configuration on another server , but they all pointing to 37.190.144.15, so there should be no conflicts

1 Like

There must be some name overlap; so that nginx is serving that name from another root.
grep -ERi 'server_name|bluedental.com|_default_' /etc/nginx/

1 Like