Website redirect After Installing SSL to notathourize

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

after Installing SSL Website Redirect to

and with website is working fine

Please let me Know What i need To Improve to Fix This Issue.


1 Like

Start by having a look at:
SSL Server Test: (Powered by Qualys SSL Labs)

1 Like


i am not getting actual issues why the site redirects to notauthorise page...

1 Like

I don't get any redirect to any "notathourize" (? spelling?) when I look at the HTTPS site:

curl -LIv

This returns:

osiris@erazer ~ $ curl -LIv
*   Trying
* Connected to ( port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*  CAfile: /etc/ssl/certs/ca-certificates.crt
*  CApath: /etc/ssl/certs
* TLSv1.3 (OUT), TLS handshake, Client hello (1):
* TLSv1.3 (IN), TLS handshake, Server hello (2):
* TLSv1.2 (IN), TLS handshake, Certificate (11):
* TLSv1.2 (IN), TLS handshake, Server key exchange (12):
* TLSv1.2 (IN), TLS handshake, Server finished (14):
* TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
* TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
* TLSv1.2 (OUT), TLS handshake, Finished (20):
* TLSv1.2 (IN), TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* ALPN, server accepted to use h2
* Server certificate:
*  subject:
*  start date: Jul 22 08:04:05 2021 GMT
*  expire date: Oct 20 08:04:03 2021 GMT
*  subjectAltName: host "" matched cert's ""
*  issuer: C=US; O=Let's Encrypt; CN=R3
*  SSL certificate verify ok.
* Using HTTP2, server supports multi-use
* Connection state changed (HTTP/2 confirmed)
* Copying HTTP/2 data in stream buffer to connection buffer after upgrade: len=0
* Using Stream ID: 1 (easy handle 0x534f4cf3dd90)
> Host:
> user-agent: curl/7.77.0
> accept: */*
< HTTP/2 200 
HTTP/2 200 
< cache-control: private
cache-control: private
< content-length: 115410
content-length: 115410
< content-type: text/html; charset=utf-8
content-type: text/html; charset=utf-8
< server: Microsoft-IIS/10.0
server: Microsoft-IIS/10.0
< x-aspnetmvc-version: 5.2
x-aspnetmvc-version: 5.2
< x-aspnet-version: 4.0.30319
x-aspnet-version: 4.0.30319
< x-powered-by: ASP.NET
x-powered-by: ASP.NET
< x-powered-by-plesk: PleskWin
x-powered-by-plesk: PleskWin
< date: Sat, 24 Jul 2021 08:20:54 GMT
date: Sat, 24 Jul 2021 08:20:54 GMT

* Connection #0 to host left intact
osiris@erazer ~ $ 

As you can see that request returned more than 100 kB of data (without the -I curl option, my terminal window filled up with HTML..) and not a redirect.

Any redirect you're seeing is probably cached in your browser. Try deleting the browser cache and try again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Your site supports very insecure ciphers:

You should probably remove all those bad ciphers and then delete the cert in use.
Replacing it with a new cert and new private key.