Website is not accessible after installing SSL certificate for .ch domain

Hey, you guys!

I have VPS server which is hosted by OVH. I want to host there a couple of simple websites that are basically a business card. I managed to deploy one webiste, installed SSL certificate and everything is working fine. Today I wanted to deploy another website, so I followed normal procedure, build application, run it on docker and served over 8080 port. It worked fine if I accessed it by IP so I proceeded to configure Nginx:

My domain is:

All worked fine. Website was served over http so I proceeded with installation of SSL certificate:

I ran this command: sudo certbot --nginx -d -d

It produced this output: SSL certificate was installed.

My web server is (include version):
Distributor ID: Ubuntu
Description: Ubuntu 23.04
Release: 23.04
Codename: lunar

My hosting provider:

The version of my client is: certbot 2.1.0

However, website is not working. I got only following message in Chrome: This site can’t be reached The connection was reset.

I checked the SSL status on: SSL Checker and all looks good.

I have even used my spare domain to check if the SSL will be applied correctly and it works -

I am seriously perplexed...It looks like the reason it is not working is because it's swiss domain? Or am I missing here something?

Edit: I purchased .com domain - and it all works fine. It must be something with swiss domain then. I also asked OVH for support.

That's unlikely.

Check if your DNS and your nginx config are the same.


Maybe just try restarting Chrome?

Your .ch domain looks fine with various tools such as this one


It seems that website was blocked by my Internet provider - Swisscom. It looks they have some policy that they block swiss websites that are not served via https and initially I was testing it over http and got warning from Swisscom that "site might be unsafe". When I disconnect wifi the site works all fine. I would not expect this might be caused by Internet provider!

Anyway, it works all fine now.

Thanks for help


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.