Website broken after running certbot --apache

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:steven-price.co.uk

I ran this command: sudo certbot --apache

It produced this output:it worked

My web server is (include version): Apache/2.4.38

The operating system my web server runs on is (include version): raspian buster

My hosting provider, if applicable, is: local host

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot 0.31.0

Hello

I’m hoping someone can help me.

I had a nextcloud server running today, which was created with the help of this tutorial:

I set up a domain name last night, using freedns.afraid.org as a DDNS.

Once that was working I ran the command certbot --apache and all seemed to go well…

however I am unable to access my site at all. I’m either being shown the domain registrars website in progress banner, or getting internal errors/time outs.

I am unable to access mysite at all :frowning:

I’ve tried disabling RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

However it’s the same response.

Any suggestions welcome.

thanks.

Hi @thegoatboy

I don’t understand your question.

Checking the url in my browser that works - a redirect to your nextcloud login:

And your certificate is new and works ( https://check-your-website.server-daten.de/?q=steven-price.co.uk ):

CN=steven-price.co.uk
	10.10.2019
	08.01.2020
expires in 90 days	steven-price.co.uk - 1 entry

Your www version doesn’t work, there is a http status 400 - Bad Request.

But that’s expected, because you have to add the domain as allowed domain.

Hey,

Thanks for the reply.

I’ve masked my ip address with a vpn and I can now access my site.

Seems like the error only occurs if I am using the same ip address as the host.

Any ideas what would be causing that?

And is there a fix?

1 Like

That’s curious. No idea, why you have such a result.

Perhaps you have a wrong local dns setup, so you use the wrong ip address.

Seems like a common error.

If I get a solution, I’ll post back.

1 Like