Webserver dont work with certificate

Hi!
I created a certificate with certbot and i add it to my web application (filebrowser) but it doesnt work, if I try to open the page with https:// the browser says: Unable to connect. The filebrowser console prints this out sometimes: http: TLS handshake error from [2a02:ab88:7200:d600:f42f:320e:56de:ced7]:37128: EOF. I tried to open up an issue on the filebrowser's github page but nobody answered. Can you please help me figure out why is this happening (and sorry for my english)?

My domain is: files.soxd.hu

The operating system my web server runs on is (include version): Linux Mint 20.3

I can login to a root shell on my machine (yes or no, or I don't know): yes

The version of my client is: certbot 2.8.0

FYI - No IPv4 Address exists

>nmap -Pn -p80,443 files.soxd.hu
Starting Nmap 7.94 ( https://nmap.org ) at 2023-12-07 16:49 UTC
Warning: Hostname files.soxd.hu resolves, but not to any IPv4 address. Try scanning with -6
Failed to resolve "files.soxd.hu".
WARNING: No targets were specified, so 0 hosts scanned.
Nmap done: 0 IP addresses (0 hosts up) scanned in 1.39 seconds

IPv6 Port 443 is Closed, therefor you cannot connect to it.

>nmap -6 -Pn -p80,443 files.soxd.hu
Starting Nmap 7.94 ( https://nmap.org ) at 2023-12-07 16:49 UTC
Nmap scan report for files.soxd.hu (2a02:ab88:7200:d600:f42f:320e:56de:ced7)
Host is up (0.17s latency).

PORT    STATE  SERVICE
80/tcp  open   http
443/tcp closed https

Nmap done: 1 IP address (1 host up) scanned in 1.25 seconds
1 Like

I know the ipv6 thing, i just want to use with ipv4 but i have the firewall disabled on the router and the 443 port allowed my computer's (ufw) firewall so I dont know why the 443 port closed.

And I find this using curl

>curl -6 http://files.soxd.hu/test
Client sent an HTTP request to an HTTPS server.
1 Like

because you entered http:// i think

HTTP live on Port 80 in general, but you are serving HTTPS it would seem.

2 Likes
>curl -6 files.soxd.hu
Client sent an HTTP request to an HTTPS server.

then what should I do?

Configure your webserver to offer HTTPS on Port 443 and HTTP on Port 80.

>curl -6 -Ii https://files.soxd.hu:80/test
HTTP/1.1 404 Not Found
Cache-Control: no-cache, no-store, must-revalidate
Content-Type: text/plain; charset=utf-8
X-Content-Type-Options: nosniff
Date: Thu, 07 Dec 2023 16:59:07 GMT
Content-Length: 14
3 Likes

I fixed it by setting the port to 443 in the filebrowser's config and now it works. Thank you!!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.