Webroot can't update my certs anymore

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command:

  • sudo certbot renew
  • sudo certbot certonly --webroot -w /home/pi/share/DC.InvoiceSystem/public/ -d facturatie.doggiecreations.nl

It produced this output:
Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for facturatie.doggiecreations.nl
Waiting for verification…
Cleaning up challenges
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/facturatie.doggiecreations.nl/fullchain.pem (failure)

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/facturatie.doggiecreations.nl/fullchain.pem (failure)

1 renew failure(s), 0 parse failure(s)


  • The following errors were reported by the server:

    Domain: facturatie.doggiecreations.nl
    Type: connection
    Detail: Fetching
    Connection refused

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):
nodejs server v10.16.0
The operating system my web server runs on is (include version):
Raspbian GNU/Linux 10 (buster)
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 0.31.0

This is the 3rd time I’m updating the certificate with certbot but this time I was to last (certificate expired) and now it won’t create a new one. :frowning:

1 Like

Do you have any idea why Let’s Encrypt is getting a “connection refused” error when trying to access http://facturatie.doggiecreations.nl/?

I can access it right now.

Could Let’s Encrypt’s IP addresses be blocked?

Are you stopping the web server before renewing? Could there be a Certbot hook doing so?


You sir, you deserve the highest possible digital Corona-free complement there is!

It’s the question “Are you stopping the web server before renewing?” that got me thinking.

I’m running PM2 and it’s watching my files, when it detects a change it’ll restart.

I’ve disabled the watch and rerun sudo certbot renew and now it works like a charm!

Thank you so much!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.