Webmail icewarp + dominio

I have the mail server on a different IP address than the site. By enabling the certificate, the domain is protected, but the webmail is not. I am going crazy. HELP

bitcompany.eu
webmail.bitcompany.eu:32000/webmail/

2 Likes

Hello @bitcompany Welcome to the community.

Your certificates cover:

bitcompany.eu
webmail.bitcompany.eu
www.bitcompany.eu

It would be easy to say that the ip's dont matter and just install the certificate on the webmail subdomain. But it is impossible to know how to help you resolve your issue without knowing the answers to the questionnaire presented to you when you opened this thread. Guessing only complicates helping you out and creates unnecessary "overhead" to those who want to volunteer to help you. :thinking:

Especially:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is?

Are you hosting your sites yourself?

Do you have access to your webmail server ?

Same Location?

Can you login to a root shell on the webmail server?

The more information you provide will result in a much quicker resolution to your issue.

3 Likes

the questions on the questionnaire are not so clear if Google translates them automatically, and then you too are cryptic: where do I find the questionnaire?

2 Likes

Hi @bitcompany,

It looks from your site information like you are an Italian speaker.

Unfortunately we have no official translation of the questionnaire into Italian but people are welcome to use any language on this forum, and perhaps a fluent speaker can help. For my part, I can read Italian but not speak it.

The questionnaire appears automatically whenever someone creates a new topic in the Help category on the forum. The version posted by @Rip is a paraphrase. Here is the Google Translate version of the original, official version of the questionnaire.


Compila i campi sottostanti in modo che possiamo aiutarti meglio. Nota: è necessario fornire il nome del dominio per ottenere assistenza. I nomi di dominio per i certificati emessi sono tutti resi pubblici nei log di Certificate Transparency (ad es. crt.sh | example.com), quindi trattenere il tuo nome di dominio qui non aumenta la segretezza, ma ci rende solo più difficile fornire aiuto.

Il mio dominio è:

Ho eseguito questo comando:

Ha prodotto questo output:

Il mio server web è (includi versione):

Il sistema operativo su cui gira il mio server web è (include la versione):

Il mio provider di hosting, se applicabile, è:

Posso accedere a una shell di root sulla mia macchina (sì o no, o non lo so):

Sto utilizzando un pannello di controllo per gestire il mio sito (no, o fornire il nome e la versione del pannello di controllo):

La versione del mio client è (ad es. Output di certbot --version o certbot-auto --version se stai usando Certbot):

4 Likes

In this case the most important information is probably:

  • What kind of software do you use on both servers?
  • How do you administer both servers? What kind of access do you have?
  • How did you obtain your existing certificate? What steps did you follow? Did you use a control panel, or some other software?

or via Google Translate

  • Che tipo di software usi su entrambi i server?
  • Come amministri entrambi i server? Che tipo di accesso hai?
  • Come hai ottenuto il tuo certificato esistente? Quali passi hai seguito? Hai utilizzato un pannello di controllo o qualche altro software?
3 Likes

Grazie Schoen per l'attenzione.
il server è uno solo e utilizzo windows server 2019
sono l'amministratore del server
ottenuto tramite icewarp ( pannello di richiesta per certificato per quanto riguarda la posta )
Sulla stessa macchina, ma in altro indirizzo IP è installato Plesk, con il quale gestisco il dominio web.

In pratica non riuscivo a far capire al certificato che avevo il sito web sull'indirizzo 82.165.254.63 mentre la posta e il webmail rispondono all'indirizzo 82.165.243.251.
Nella nottata passata a ragionarci su, sono riusito a risolvere. In pratica ho un server con due indirizzi IPV4 con installato due differenti server di posta ( Icewarp e Mailenable ) che funzionano sulle stesse porte ( tranne webmail ) ma su i due indirizzi dedicati.
Ora l'ultima cosa che mi manca è come creare un "rewrite" per fa si che chi accede al webmail di Icewarp non debba scrivere la porta 32000/32001, ma venga reindirizzato a tali porte semplicemente scrivendo il nome del webmail.
il dominio è bitcompany.eu ( 82.165.254.63 ) e la mail/webmail è bitcompany.eu:32001/webmail/ ( 82.165.243.251 ).
Il problema che avevo citato ora è risolto.
Grazie

3 Likes

Mi dispiace se il mio tono è sembrato duro. Non era mia intenzione essere scortese. Per fortuna @schoen stato in grado di aiutarti a risolvere le tue domande.
In bocca al lupo!

3 Likes

this morning I returned to the starting point. On http the webmail works, on https it doesn't.
Obviously I can't understand how to enable the certificate, otherwise I wouldn't know why it doesn't work.
http://webmail.mailserverpro.it:32000/webmail/ = work
https://webmail.mailserverpro.it:32001/webmail/ = not work

1 Like

NB: I have changed domains, but in reality I have only replaced one to the other, with the exact same settings

1 Like

Thanks. You weren't absolutely hard, it was I who didn't understand the "meaning". But I haven't solved it yet. I thought

1 Like

Ok @bitcompany so you still need help. I can't tell if you prefer English or Italian to communicate. My Italian is from google.
I need to step out but let me ping @griffin and see if he can lend a hand here.

Ok, quindi hai ancora bisogno di aiuto. Non so se preferisci l'inglese o l'italiano per comunicare. Il mio italiano è di Google.
Devo uscire ma fammi pingare @griffin e vedere se può dare una mano qui.

2 Likes

ok, in english is perfect!!!

1 Like

When I try to access your HTTPS site I get this error: SSL_ERROR_RX_CERTIFICATE_REQUIRED_ALERT. This errors means that your website requested a client certificate from my browser. That's probably due to a misconfiguration of your website.

Is there anything in your IceWarp documentation that says something like "require client certificate?" If so you should turn that off (assuming you intend to log in with a username and password, which is much more common than using client certificates to log in).

1 Like

@bitcompany

I concur with @jsha's analysis. I'm not exactly sure to what extent things don't work, but addressing what @jsha has mentioned is the first step.

Try downloading this PDF and look at pp 18-20 about the Restrictions tab for the option related to Enable/disable private certificates (Private Certificates dialoque in user Options/Accounts).

@Rip

Thank you for pinging me in this. Sorry I couldn't get here sooner. When it rains it poors and I've been running for hours up until now. :upside_down_face:

@jsha

Thanks much for fielding this one. :slightly_smiling_face:

1 Like

OK. controlato. Il problema non sta nel certificato, ma nell'utilizzo del "localhost" . evidentemente c'è un routing che mi sfugge.
Ora ho applicato l'IP 127.0.0.1 al webmail e tutto funziona correttamente.
Non voglio indagare oltre, aspetto i problemi al rinnovo del certificato, per capire :smiley:
GRazie per la vostra assistenza. sono felice di aver trovato voi qui!

2 Likes

OK. controlled. The problem is not in the certificate, but in the use of the "localhost". obviously there is a routing that escapes me.
Now I have applied the IP 127.0.0.1 to the webmail and everything works fine.
I do not want to investigate further, I am waiting for the problems to renew the certificate, to understand: smiley:
Thanks for your assistance. I am happy to have found you here!

2 Likes

Glad it's working! :slightly_smiling_face:

If you run into anything, just let us know.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.